summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0105-spelling_errors.patch19
-rw-r--r--debian/patches/0110-Fix-Build-error.patch19
-rw-r--r--debian/patches/0700-ayatana-appindicator.patch77
-rw-r--r--debian/patches/series3
4 files changed, 118 insertions, 0 deletions
diff --git a/debian/patches/0105-spelling_errors.patch b/debian/patches/0105-spelling_errors.patch
new file mode 100644
index 0000000..9b14dc9
--- /dev/null
+++ b/debian/patches/0105-spelling_errors.patch
@@ -0,0 +1,19 @@
+Description: Fix spelling errors
+Author: Jörg Frings-Fürst <debian@jff.email>
+Forwarded: https://github.com/Simmesimme/Gnome-Pie/issues/165
+Last-Update: 2018-09-07
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/src/themes/theme.vala
+===================================================================
+--- trunk.orig/src/themes/theme.vala
++++ trunk/src/themes/theme.vala
+@@ -179,7 +179,7 @@ public class Theme : GLib.Object {
+ dialog.destroy();
+
+ } else {
+- var message = _("An error occured while exporting the theme \"%s\"! Please check the console output.").printf(this.name);
++ var message = _("An error occurred while exporting the theme \"%s\"! Please check the console output.").printf(this.name);
+ var dialog = new Gtk.MessageDialog(null, Gtk.DialogFlags.MODAL,
+ Gtk.MessageType.ERROR, Gtk.ButtonsType.CLOSE, message);
+ dialog.run();
diff --git a/debian/patches/0110-Fix-Build-error.patch b/debian/patches/0110-Fix-Build-error.patch
new file mode 100644
index 0000000..0ec2925
--- /dev/null
+++ b/debian/patches/0110-Fix-Build-error.patch
@@ -0,0 +1,19 @@
+Description: Fix build errors
+Author: Jörg Frings-Fürst <debian@jff.email>
+forwarded: https://github.com/Simmesimme/Gnome-Pie/issues/177
+Last-Update: 2020-05-31
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/src/actions/action.vala
+===================================================================
+--- trunk.orig/src/actions/action.vala
++++ trunk/src/actions/action.vala
+@@ -69,7 +69,7 @@ public abstract class Action : GLib.Obje
+ /// C'tor, initializes all members.
+ /////////////////////////////////////////////////////////////////////
+
+- public Action(string name, string icon, bool is_quickaction) {
++ Action(string name, string icon, bool is_quickaction) {
+ GLib.Object(name : name, icon : icon, is_quickaction : is_quickaction);
+ }
+
diff --git a/debian/patches/0700-ayatana-appindicator.patch b/debian/patches/0700-ayatana-appindicator.patch
new file mode 100644
index 0000000..d8a9905
--- /dev/null
+++ b/debian/patches/0700-ayatana-appindicator.patch
@@ -0,0 +1,77 @@
+Description: Switch to Ayatana AppIndicator
+Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=907551
+Forwarded: not-needed
+Last-Update: 2018-09-07
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,7 +26,7 @@
+ find_package(PkgConfig)
+
+ pkg_check_modules(GTK3 REQUIRED gtk+-3.0)
+-pkg_check_modules(INDICATOR3 appindicator3-0.1)
++pkg_check_modules(INDICATOR3 ayatana-appindicator3-0.1)
+ pkg_check_modules(WNCK REQUIRED libwnck-3.0)
+ pkg_check_modules(BAMF libbamf3)
+ pkg_check_modules(GIO REQUIRED gio-unix-2.0)
+@@ -75,11 +75,7 @@
+ pkg_check_modules(GMENU REQUIRED libgnome-menu)
+ endif (${GMENU3_FOUND})
+
+-# notify application of presence of libappindicator
+-if (${INDICATOR_FOUND})
+- LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
+- LIST(APPEND VALA_DEFINES --define HAVE_APPINDICATOR)
+-endif (${INDICATOR_FOUND})
++# notify application of presence of libayatana-appindicator
+ if (${INDICATOR3_FOUND})
+ LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
+ LIST(APPEND VALA_DEFINES --define HAVE_APPINDICATOR)
+@@ -97,7 +93,6 @@
+ ${GTK3_LIBRARIES}
+ ${CAIRO_LIBRARIES}
+ ${GEE_LIBRARIES}
+- ${INDICATOR_LIBRARIES}
+ ${INDICATOR3_LIBRARIES}
+ ${XML_LIBRARIES}
+ ${XTST_LIBRARIES}
+@@ -117,7 +112,6 @@
+ ${GTK3_LIBRARY_DIRS}
+ ${CAIRO_LIBRARY_DIRS}
+ ${GEE_LIBRARY_DIRS}
+- ${INDICATOR_LIBRARY_DIRS}
+ ${INDICATOR3_LIBRARY_DIRS}
+ ${XML_LIBRARY_DIRS}
+ ${XTST_LIBRARY_DIRS}
+@@ -134,7 +128,6 @@
+ ${GTK3_INCLUDE_DIRS}
+ ${CAIRO_INCLUDE_DIRS}
+ ${GEE_INCLUDE_DIRS}
+- ${INDICATOR_INCLUDE_DIRS}
+ ${INDICATOR3_INCLUDE_DIRS}
+ ${XML_INCLUDE_DIRS}
+ ${XTST_INCLUDE_DIRS}
+@@ -166,12 +159,8 @@
+ libarchive
+ )
+
+-if (${INDICATOR_FOUND})
+- LIST(APPEND VALA_PKGS appindicator-0.1)
+-endif (${INDICATOR_FOUND})
+-
+ if (${INDICATOR3_FOUND})
+- LIST(APPEND VALA_PKGS appindicator3-0.1)
++ LIST(APPEND VALA_PKGS ayatana-appindicator3-0.1)
+ endif (${INDICATOR3_FOUND})
+
+ if (${GMENU3_FOUND})
+@@ -210,7 +199,6 @@
+ message( " GTK3_LIBRARIES = ${GTK3_LIBRARIES}" )
+ message( " CAIRO_LIBRARIES = ${CAIRO_LIBRARIES}" )
+ message( " GEE_LIBRARIES = ${GEE_LIBRARIES}" )
+-message( " INDICATOR_LIBRARIES = ${INDICATOR_LIBRARIES}" )
+ message( " INDICATOR3_LIBRARIES = ${INDICATOR3_LIBRARIES}" )
+ message( " XML_LIBRARIES = ${XML_LIBRARIES}" )
+ message( " XTST_LIBRARIES = ${XTST_LIBRARIES}" )
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..cf48a33
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+0110-Fix-Build-error.patch
+0700-ayatana-appindicator.patch
+0105-spelling_errors.patch