Description: Fix FTBFS with vala 0.42
Origin: upstream, https://github.com/Simmesimme/Gnome-Pie/commit/86412ee09b7f8bc11f163bc8b6c3a061be279c43
Bug: https://github.com/Simmesimme/Gnome-Pie/issues/164
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=907943
Forwarded: not-needed
Last-Update: 2018-09-07
--
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
Index: trunk/src/utilities/archiveReader.vala
===================================================================
--- trunk.orig/src/utilities/archiveReader.vala
+++ trunk/src/utilities/archiveReader.vala
@@ -84,9 +84,13 @@ public class ArchiveReader : GLib.Object
             if (entry.size() > 0) {
                 while (true) {
                     size_t offset, size;
-                    void *buff;
+                    uint8[] buff;
 
+#if VALA_0_42
+                    r = this.archive.read_data_block(out buff, out offset);
+#else
                     r = this.archive.read_data_block(out buff, out size, out offset);
+#endif
                     if (r == Archive.Result.EOF) {
                         break;
                     }
@@ -96,7 +100,11 @@ public class ArchiveReader : GLib.Object
                         return false;
                     }
 
+#if VALA_0_42
+                    this.writer.write_data_block(buff, offset);
+#else
                     this.writer.write_data_block(buff, size, offset);
+#endif
                 }
             }
 
Index: trunk/src/utilities/archiveWriter.vala
===================================================================
--- trunk.orig/src/utilities/archiveWriter.vala
+++ trunk/src/utilities/archiveWriter.vala
@@ -112,13 +112,17 @@ public class ArchiveWriter : GLib.Object
         if (this.archive.write_header(entry) == Archive.Result.OK) {
             try {
                 var reader = File.new_for_path(path).read();
-                uint8 buffer[4096];
+                uint8[] buffer = new uint8[4096];
 
-                var len = reader.read(buffer);
+                buffer.length = (int) reader.read(buffer);
 
-                while(len > 0) {
-                    this.archive.write_data(buffer, len);
-                    len = reader.read(buffer);
+                while(buffer.length > 0) {
+#if VALA_0_42
+                    this.archive.write_data(buffer);
+#else
+                    this.archive.write_data(buffer, buffer.length);
+#endif
+                    buffer.length = (int) reader.read(buffer);
                 }
 
                 this.archive.finish_entry();