summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2023-03-15 20:36:32 +0100
committerJörg Frings-Fürst <debian@jff.email>2023-03-15 20:36:32 +0100
commit5eca20c9805ec489c6860c793ee66e82b79836d1 (patch)
treefb7a5856b53fb2fa195793efc7f8c38d185b9f42 /configure.ac
parent899cb94807a04dcd6e8b045c7d901d2852273345 (diff)
parentd602f4fb516292c297072bd924289eea37b45fa2 (diff)
Update upstream source from tag 'upstream/3.1.9'
Update to upstream version '3.1.9' with Debian dir 230e687d678f3fcb6df41a4ed6de80795bdd1f93
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 01525c8..821d56b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(ipmiutil,3.1.8)
+AC_INIT(ipmiutil,3.1.9)
AC_CONFIG_SRCDIR(util/ipmiutil.c)
echo "ipmiutil version ${PACKAGE_VERSION}"
AC_CONFIG_HEADERS(config.h)
@@ -333,7 +333,7 @@ else
echo $ECHO_N "checking compile sign warning flags ... $ECHO_C"
cfwarn="-Wno-pointer-sign -Wno-sign-conversion"
# want "-Wno-unused-result", but unrecognized
- echo "int main() { return(1); }" >$tmpc
+ echo "int main(void) { return(1); }" >$tmpc
$CC -o $tmpo -c $cfwarn $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then
cfwarn=
@@ -344,7 +344,7 @@ else
rm -f $tmpc $tmpo >/dev/null 2>&1
echo $ECHO_N "checking compile gnu warning flags ... $ECHO_C"
cfgnu="-Wgnu-designator"
- echo "int main() { return(1); }" >$tmpc
+ echo "int main(void) { return(1); }" >$tmpc
$CC -o $tmpo -c $cfgnu $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then
cfgnu=
@@ -355,7 +355,7 @@ else
rm -f $tmpc $tmpo >/dev/null 2>&1
echo $ECHO_N "checking strict aliasing warning flags ... $ECHO_C"
cfalias="-fno-strict-aliasing"
- echo "int main() { return(1); }" >$tmpc
+ echo "int main(void) { return(1); }" >$tmpc
$CC -o $tmpo -c $cfalias $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then
cfalias=
@@ -366,7 +366,8 @@ else
rm -f $tmpc $tmpo >/dev/null 2>&1
echo $ECHO_N "checking compile fortify flags ... $ECHO_C"
cfhard="-fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
- echo "int main() { alloca(100); return(1); }" >$tmpc
+ echo "#include <alloca.h>
+ int main(void) { alloca(100); return(1); }" >$tmpc
$CC -o $tmpo $cfhard $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then
cfhard=