summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure212
1 files changed, 155 insertions, 57 deletions
diff --git a/configure b/configure
index 47bb9f9..5ffb08c 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.59.
+# Generated by GNU Autoconf 2.59 for ipmiutil 2.9.5.
#
# Copyright (C) 2003 Free Software Foundation, Inc.
# This configure script is free software; the Free Software Foundation
@@ -419,14 +419,15 @@ SHELL=${CONFIG_SHELL-/bin/sh}
: ${ac_max_here_lines=38}
# Identity of this package.
-PACKAGE_NAME=
-PACKAGE_TARNAME=
-PACKAGE_VERSION=
-PACKAGE_STRING=
-PACKAGE_BUGREPORT=
+PACKAGE_NAME='ipmiutil'
+PACKAGE_TARNAME='ipmiutil'
+PACKAGE_VERSION='2.9.5'
+PACKAGE_STRING='ipmiutil 2.9.5'
+PACKAGE_BUGREPORT=''
ac_unique_file="util/ipmiutil.c"
ac_default_prefix=/usr
+ac_default_prefix=/usr
# Factoring default headers for most tests.
ac_includes_default="\
#include <stdio.h>
@@ -464,7 +465,7 @@ ac_includes_default="\
# include <unistd.h>
#endif"
-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE LN_S SED CPP EGREP build build_cpu build_vendor build_os host host_cpu host_vendor host_os ECHO AR ac_ct_AR RANLIB ac_ct_RANLIB CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE CXXCPP F77 FFLAGS ac_ct_F77 LIBTOOL LANDESK_CFLAGS LANDESK_LDADD IA64_CFLAGS LANPLUS_CFLAGS LANPLUS_LDADD LANPLUS_LIB LANPLUS_CRYPTO LANPLUS_SAM LD_SAMX GPL_CFLAGS OS_CFLAGS OS_LFLAGS OS_DRIVERS PKG_DIR INIT_DIR LIB_DIR INS_LIB SUBDIR_S CROSS_CFLAGS CROSS_LFLAGS SYSTEMD_DIR SHR_LINK LIBOBJS LTLIBOBJS'
+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE LN_S SED CPP EGREP build build_cpu build_vendor build_os host host_cpu host_vendor host_os ECHO AR ac_ct_AR RANLIB ac_ct_RANLIB CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE CXXCPP F77 FFLAGS ac_ct_F77 LIBTOOL LANDESK_CFLAGS LANDESK_LDADD WITH_PKG_CONFIG_TRUE WITH_PKG_CONFIG_FALSE IA64_CFLAGS LANPLUS_CFLAGS LANPLUS_LDADD LANPLUS_LIB LANPLUS_CRYPTO LANPLUS_SAM LIBSENSORS SAM2OBJ LD_SAMX GPL_CFLAGS OS_CFLAGS OS_LFLAGS OS_DRIVERS PKG_DIR INIT_DIR LIB_DIR INS_LIB SUBDIR_S CROSS_CFLAGS CROSS_LFLAGS SYSTEMD_DIR SHR_LINK pkgconfigdir LIBOBJS LTLIBOBJS'
ac_subst_files=''
# Initialize some variables set by options.
@@ -953,7 +954,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures this package to adapt to many kinds of systems.
+\`configure' configures ipmiutil 2.9.5 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1018,7 +1019,9 @@ _ACEOF
fi
if test -n "$ac_init_help"; then
-
+ case $ac_init_help in
+ short | recursive ) echo "Configuration of ipmiutil 2.9.5:";;
+ esac
cat <<\_ACEOF
Optional Features:
@@ -1036,9 +1039,11 @@ Optional Features:
--enable-landesk adds landesk library support [default=no]
--disable-lanplus disable lanplus support [default=enabled]
--enable-sha256 build with SHA256 support, requires later openssl.
+ --enable-useflags include environment CFLAGS and LDFLAGS.
--enable-standalone build standalone, with no GPL or LanPlus libs.
+ --enable-libsensors build libipmiutil with sensor modules [default=no]
--enable-gpl build with some GPL code [default=no]
- --enable-systemd enable systemd service type=notify support and %_unitdir [default=disabled]
+ --enable-systemd enable systemd service type=notify support and %_unitdir [default=disabled]
Optional Packages:
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
@@ -1048,6 +1053,9 @@ Optional Packages:
both]
--with-tags[=TAGS]
include additional configurations [automatic]
+ --with-pkgconfig-dir=PATH
+ where to install pkg-config *.pc files
+ (EPREFIX/lib/pkgconfig)
Some influential environment variables:
CC C compiler command
@@ -1161,6 +1169,8 @@ fi
test -n "$ac_init_help" && exit 0
if $ac_init_version; then
cat <<\_ACEOF
+ipmiutil configure 2.9.5
+generated by GNU Autoconf 2.59
Copyright (C) 2003 Free Software Foundation, Inc.
This configure script is free software; the Free Software Foundation
@@ -1173,7 +1183,7 @@ cat >&5 <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by $as_me, which was
+It was created by ipmiutil $as_me 2.9.5, which was
generated by GNU Autoconf 2.59. Invocation command line was
$ $0 $@
@@ -1501,6 +1511,19 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+
+
+
+
+
+
+
+
+echo "ipmiutil version ${PACKAGE_VERSION}"
+ ac_config_headers="$ac_config_headers config.h"
+
+
am__api_version="1.9"
ac_aux_dir=
for ac_dir in $srcdir $srcdir/.. $srcdir/../..; do
@@ -1807,8 +1830,8 @@ fi
# Define the identity of the package.
- PACKAGE=ipmiutil
- VERSION=2.9.4
+ PACKAGE='ipmiutil'
+ VERSION='2.9.5'
cat >>confdefs.h <<_ACEOF
@@ -1938,8 +1961,6 @@ am__tar='${AMTAR} chof - "$$tardir"'; am__untar='${AMTAR} xf -'
- ac_config_headers="$ac_config_headers config.h"
-
@@ -3817,9 +3838,9 @@ echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&
echo "$as_me: WARNING: $ac_header: in the future, the compiler will take precedence" >&2;}
(
cat <<\_ASBOX
-## ------------------------------------------ ##
-## Report this to the AC_PACKAGE_NAME lists. ##
-## ------------------------------------------ ##
+## ----------------------------------- ##
+## Report this to the ipmiutil lists. ##
+## ----------------------------------- ##
_ASBOX
) |
sed "s/^/$as_me: WARNING: /" >&2
@@ -4321,9 +4342,9 @@ echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&
echo "$as_me: WARNING: $ac_header: in the future, the compiler will take precedence" >&2;}
(
cat <<\_ASBOX
-## ------------------------------------------ ##
-## Report this to the AC_PACKAGE_NAME lists. ##
-## ------------------------------------------ ##
+## ----------------------------------- ##
+## Report this to the ipmiutil lists. ##
+## ----------------------------------- ##
_ASBOX
) |
sed "s/^/$as_me: WARNING: /" >&2
@@ -5707,7 +5728,7 @@ ia64-*-hpux*)
;;
*-*-irix6*)
# Find out which ABI we are using.
- echo '#line 5710 "configure"' > conftest.$ac_ext
+ echo '#line 5731 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -6011,9 +6032,9 @@ echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&
echo "$as_me: WARNING: $ac_header: in the future, the compiler will take precedence" >&2;}
(
cat <<\_ASBOX
-## ------------------------------------------ ##
-## Report this to the AC_PACKAGE_NAME lists. ##
-## ------------------------------------------ ##
+## ----------------------------------- ##
+## Report this to the ipmiutil lists. ##
+## ----------------------------------- ##
_ASBOX
) |
sed "s/^/$as_me: WARNING: /" >&2
@@ -6833,7 +6854,7 @@ fi
# Provide some information about the compiler.
-echo "$as_me:6836:" \
+echo "$as_me:6857:" \
"checking for Fortran 77 compiler version" >&5
ac_compiler=`set X $ac_compile; echo $2`
{ (eval echo "$as_me:$LINENO: \"$ac_compiler --version </dev/null >&5\"") >&5
@@ -7896,11 +7917,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7899: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7920: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:7903: \$? = $ac_status" >&5
+ echo "$as_me:7924: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -8164,11 +8185,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:8167: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:8188: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:8171: \$? = $ac_status" >&5
+ echo "$as_me:8192: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -8268,11 +8289,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:8271: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:8292: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:8275: \$? = $ac_status" >&5
+ echo "$as_me:8296: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -9737,7 +9758,7 @@ linux*)
libsuff=
case "$host_cpu" in
x86_64*|s390x*|powerpc64*)
- echo '#line 9740 "configure"' > conftest.$ac_ext
+ echo '#line 9761 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -10634,7 +10655,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 10637 "configure"
+#line 10658 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -10734,7 +10755,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 10737 "configure"
+#line 10758 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -13077,11 +13098,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:13080: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:13101: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:13084: \$? = $ac_status" >&5
+ echo "$as_me:13105: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -13181,11 +13202,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:13184: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:13205: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:13188: \$? = $ac_status" >&5
+ echo "$as_me:13209: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -13717,7 +13738,7 @@ linux*)
libsuff=
case "$host_cpu" in
x86_64*|s390x*|powerpc64*)
- echo '#line 13720 "configure"' > conftest.$ac_ext
+ echo '#line 13741 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -14775,11 +14796,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:14778: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:14799: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:14782: \$? = $ac_status" >&5
+ echo "$as_me:14803: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -14879,11 +14900,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:14882: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:14903: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:14886: \$? = $ac_status" >&5
+ echo "$as_me:14907: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -16328,7 +16349,7 @@ linux*)
libsuff=
case "$host_cpu" in
x86_64*|s390x*|powerpc64*)
- echo '#line 16331 "configure"' > conftest.$ac_ext
+ echo '#line 16352 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -17106,11 +17127,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:17109: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:17130: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:17113: \$? = $ac_status" >&5
+ echo "$as_me:17134: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -17374,11 +17395,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:17377: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:17398: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:17381: \$? = $ac_status" >&5
+ echo "$as_me:17402: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -17478,11 +17499,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:17481: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:17502: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:17485: \$? = $ac_status" >&5
+ echo "$as_me:17506: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -18947,7 +18968,7 @@ linux*)
libsuff=
case "$host_cpu" in
x86_64*|s390x*|powerpc64*)
- echo '#line 18950 "configure"' > conftest.$ac_ext
+ echo '#line 18971 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -20428,8 +20449,22 @@ if test "${enable_sha256+set}" = set; then
fi;
+GPL_CFLAGS=""
CROSS_LFLAGS=""
CROSS_CFLAGS=""
+LIBSENSORS=""
+SAM2OBJ="isensor2.o ievents2.o"
+SYSTEMD_DIR=/usr/share/ipmiutil
+
+# Check whether --enable-useflags or --disable-useflags was given.
+if test "${enable_useflags+set}" = set; then
+ enableval="$enable_useflags"
+ if test "x$enableval" = "xyes"; then
+ CROSS_CFLAGS="$CFLAGS"
+ CROSS_LFLAGS="$LDFLAGS"
+ fi
+
+fi;
# Check whether --enable-standalone or --disable-standalone was given.
if test "${enable_standalone+set}" = set; then
@@ -20454,13 +20489,21 @@ if test "${enable_standalone+set}" = set; then
fi;
+# Check whether --enable-libsensors or --disable-libsensors was given.
+if test "${enable_libsensors+set}" = set; then
+ enableval="$enable_libsensors"
+ if test "x$enableval" = "xyes"; then
+ LIBSENSORS="isensor2.o ievents2.o"
+ SAM2OBJ=""
+ fi
+
+fi;
+
# Check whether --enable-gpl or --disable-gpl was given.
if test "${enable_gpl+set}" = set; then
enableval="$enable_gpl"
if test "x$enableval" = "xyes"; then
GPL_CFLAGS="-DALLOW_GPL"
- else
- GPL_CFLAGS=""
fi
fi;
@@ -20520,6 +20563,44 @@ case "$archm" in
;;
esac
+pkgconfigdir='${libdir}/pkgconfig'
+echo "$as_me:$LINENO: checking whether to install pkg-config *.pc files" >&5
+echo $ECHO_N "checking whether to install pkg-config *.pc files... $ECHO_C" >&6
+
+# Check whether --with-pkgconfig-dir or --without-pkgconfig-dir was given.
+if test "${with_pkgconfig_dir+set}" = set; then
+ withval="$with_pkgconfig_dir"
+
+ case "${withval}" in
+ yes|auto)
+ ;;
+ no)
+ pkgconfigdir=""
+ ;;
+ *)
+ pkgconfigdir="${withval}"
+ ;;
+ esac
+
+fi;
+if test -n "${pkgconfigdir}"; then
+ echo "$as_me:$LINENO: result: using ${pkgconfigdir}" >&5
+echo "${ECHO_T}using ${pkgconfigdir}" >&6
+else
+ echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6
+fi
+
+
+if test -n "${pkgconfigdir}"; then
+ WITH_PKG_CONFIG_TRUE=
+ WITH_PKG_CONFIG_FALSE='#'
+else
+ WITH_PKG_CONFIG_TRUE='#'
+ WITH_PKG_CONFIG_FALSE=
+fi
+
+
echo $libdir |grep exec_prefix >/dev/null 2>&1
if test $? -ne 0; then
LIB_DIR="$libdir"
@@ -20723,7 +20804,10 @@ INIT_DIR=${init0}
- ac_config_files="$ac_config_files Makefile util/Makefile lib/lanplus/Makefile doc/Makefile scripts/Makefile"
+
+
+
+ ac_config_files="$ac_config_files Makefile util/Makefile lib/Makefile lib/libipmiutil.pc lib/lanplus/Makefile doc/Makefile scripts/Makefile"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure
@@ -20836,6 +20920,13 @@ echo "$as_me: error: conditional \"am__fastdepCXX\" was never defined.
Usually this means the macro was only invoked conditionally." >&2;}
{ (exit 1); exit 1; }; }
fi
+if test -z "${WITH_PKG_CONFIG_TRUE}" && test -z "${WITH_PKG_CONFIG_FALSE}"; then
+ { { echo "$as_me:$LINENO: error: conditional \"WITH_PKG_CONFIG\" was never defined.
+Usually this means the macro was only invoked conditionally." >&5
+echo "$as_me: error: conditional \"WITH_PKG_CONFIG\" was never defined.
+Usually this means the macro was only invoked conditionally." >&2;}
+ { (exit 1); exit 1; }; }
+fi
: ${CONFIG_STATUS=./config.status}
ac_clean_files_save=$ac_clean_files
@@ -21107,7 +21198,7 @@ _ASBOX
} >&5
cat >&5 <<_CSEOF
-This file was extended by $as_me, which was
+This file was extended by ipmiutil $as_me 2.9.5, which was
generated by GNU Autoconf 2.59. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -21170,7 +21261,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
-config.status
+ipmiutil config.status 2.9.5
configured by $0, generated by GNU Autoconf 2.59,
with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
@@ -21282,6 +21373,8 @@ do
# Handling of arguments.
"Makefile" ) CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"util/Makefile" ) CONFIG_FILES="$CONFIG_FILES util/Makefile" ;;
+ "lib/Makefile" ) CONFIG_FILES="$CONFIG_FILES lib/Makefile" ;;
+ "lib/libipmiutil.pc" ) CONFIG_FILES="$CONFIG_FILES lib/libipmiutil.pc" ;;
"lib/lanplus/Makefile" ) CONFIG_FILES="$CONFIG_FILES lib/lanplus/Makefile" ;;
"doc/Makefile" ) CONFIG_FILES="$CONFIG_FILES doc/Makefile" ;;
"scripts/Makefile" ) CONFIG_FILES="$CONFIG_FILES scripts/Makefile" ;;
@@ -21440,12 +21533,16 @@ s,@ac_ct_F77@,$ac_ct_F77,;t t
s,@LIBTOOL@,$LIBTOOL,;t t
s,@LANDESK_CFLAGS@,$LANDESK_CFLAGS,;t t
s,@LANDESK_LDADD@,$LANDESK_LDADD,;t t
+s,@WITH_PKG_CONFIG_TRUE@,$WITH_PKG_CONFIG_TRUE,;t t
+s,@WITH_PKG_CONFIG_FALSE@,$WITH_PKG_CONFIG_FALSE,;t t
s,@IA64_CFLAGS@,$IA64_CFLAGS,;t t
s,@LANPLUS_CFLAGS@,$LANPLUS_CFLAGS,;t t
s,@LANPLUS_LDADD@,$LANPLUS_LDADD,;t t
s,@LANPLUS_LIB@,$LANPLUS_LIB,;t t
s,@LANPLUS_CRYPTO@,$LANPLUS_CRYPTO,;t t
s,@LANPLUS_SAM@,$LANPLUS_SAM,;t t
+s,@LIBSENSORS@,$LIBSENSORS,;t t
+s,@SAM2OBJ@,$SAM2OBJ,;t t
s,@LD_SAMX@,$LD_SAMX,;t t
s,@GPL_CFLAGS@,$GPL_CFLAGS,;t t
s,@OS_CFLAGS@,$OS_CFLAGS,;t t
@@ -21460,6 +21557,7 @@ s,@CROSS_CFLAGS@,$CROSS_CFLAGS,;t t
s,@CROSS_LFLAGS@,$CROSS_LFLAGS,;t t
s,@SYSTEMD_DIR@,$SYSTEMD_DIR,;t t
s,@SHR_LINK@,$SHR_LINK,;t t
+s,@pkgconfigdir@,$pkgconfigdir,;t t
s,@LIBOBJS@,$LIBOBJS,;t t
s,@LTLIBOBJS@,$LTLIBOBJS,;t t
CEOF