summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/001-landesk_test.patch21
-rw-r--r--debian/patches/002-build.patch37
-rw-r--r--debian/patches/003-typo-man.patch18
-rw-r--r--debian/patches/series3
4 files changed, 79 insertions, 0 deletions
diff --git a/debian/patches/001-landesk_test.patch b/debian/patches/001-landesk_test.patch
new file mode 100644
index 0000000..150dce8
--- /dev/null
+++ b/debian/patches/001-landesk_test.patch
@@ -0,0 +1,21 @@
+Description: remove ifdef TEST & endif
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2014-06-04
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/util/ipmild.c
+===================================================================
+--- trunk.orig/util/ipmild.c 2014-05-26 14:23:52.000000000 +0200
++++ trunk/util/ipmild.c 2014-05-26 19:07:45.000000000 +0200
+@@ -87,9 +87,9 @@
+ extern FILE *fperr; /*defined in ipmicmd.c*/
+ extern FILE *fpdbg; /*defined in ipmicmd.c*/
+ extern ipmi_cmd_t ipmi_cmds[NCMDS];
+-#ifdef TEST
++//#ifdef TEST
+ static int ipmi_fd = -1;
+-#endif
++//#endif
+
+ int ipmi_open_ld(char fdebugcmd)
+ {
diff --git a/debian/patches/002-build.patch b/debian/patches/002-build.patch
new file mode 100644
index 0000000..dc1799e
--- /dev/null
+++ b/debian/patches/002-build.patch
@@ -0,0 +1,37 @@
+Description: add @INS_LIB@ to Makefiles
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2014-06-04
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/util/Makefile.am
+===================================================================
+--- trunk.orig/util/Makefile.am 2014-03-31 16:10:19.000000000 +0200
++++ trunk/util/Makefile.am 2014-05-26 19:11:11.998725060 +0200
+@@ -189,9 +189,9 @@
+ @INS_LIB@ cp -f isensor.h ievents.h $(DESTDIR)$(extradir)
+ @INS_LIB@ cp -f Makefile.sample $(DESTDIR)$(extradir)/Makefile
+ @INS_LIB@ cp -f $(DEV_LIB) $(DESTDIR)$(LIBDIR)
+- if [ "x$(SHRLINK)" != "x" ]; then \
++ @INS_LIB@ if [ "x$(SHRLINK)" != "x" ]; then \
+ @INS_LIB@ cp -f $(SHR_LIB) $(DESTDIR)$(LIBDIR) ; \
+- fi
++ @INS_LIB@ fi
+
+ clean-generic:
+ rm -f $(DEV_LIB) $(EXTRA_PROGRAMS) $(OLDPROGS) $(TESTPROGS) $(SHRLINK)
+Index: trunk/util/Makefile.in
+===================================================================
+--- trunk.orig/util/Makefile.in 2014-03-31 16:10:24.000000000 +0200
++++ trunk/util/Makefile.in 2014-05-26 19:11:25.698992815 +0200
+@@ -752,9 +752,9 @@
+ @INS_LIB@ cp -f isensor.h ievents.h $(DESTDIR)$(extradir)
+ @INS_LIB@ cp -f Makefile.sample $(DESTDIR)$(extradir)/Makefile
+ @INS_LIB@ cp -f $(DEV_LIB) $(DESTDIR)$(LIBDIR)
+- if [ "x$(SHRLINK)" != "x" ]; then \
++ @INS_LIB@ if [ "x$(SHRLINK)" != "x" ]; then \
+ @INS_LIB@ cp -f $(SHR_LIB) $(DESTDIR)$(LIBDIR) ; \
+- fi
++ @INS_LIB@ fi
+
+ clean-generic:
+ rm -f $(DEV_LIB) $(EXTRA_PROGRAMS) $(OLDPROGS) $(TESTPROGS) $(SHRLINK)
diff --git a/debian/patches/003-typo-man.patch b/debian/patches/003-typo-man.patch
new file mode 100644
index 0000000..2ada9ff
--- /dev/null
+++ b/debian/patches/003-typo-man.patch
@@ -0,0 +1,18 @@
+Description: typo manpages
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2014-06-04
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/doc/iseltime.8
+===================================================================
+--- trunk.orig/doc/iseltime.8 2014-03-31 16:10:19.000000000 +0200
++++ trunk/doc/iseltime.8 2014-06-29 16:06:29.843381755 +0200
+@@ -54,7 +54,7 @@
+ Use a specified IPMI LAN privilege level. 1=Callback level, 2=User level, 3=Operator level, 4=Administrator level (default), 5=OEM level.
+ .IP "-Y"
+ Yes, do prompt the user for the IPMI LAN remote password.
+-Alternatives for the password are -E or -P.
++Alternatives for the password are \-E or \-P.
+
+
+ .SH "SEE ALSO"
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5084afc
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+003-typo-man.patch
+001-landesk_test.patch
+002-build.patch