summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0105-typo.patch116
-rw-r--r--debian/patches/0110-fix_malformed_messages.patch66
-rw-r--r--debian/patches/0600-typo-man.patch66
-rw-r--r--debian/patches/0700-init.patch234
-rw-r--r--debian/patches/0705-crontab.patch20
-rw-r--r--debian/patches/series5
6 files changed, 507 insertions, 0 deletions
diff --git a/debian/patches/0105-typo.patch b/debian/patches/0105-typo.patch
new file mode 100644
index 0000000..d3934a9
--- /dev/null
+++ b/debian/patches/0105-typo.patch
@@ -0,0 +1,116 @@
+Description: some source typos
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Forwarded: Not possible because not authorized
+Last-Update: 2018-06-26
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/util/ihpm.c
+===================================================================
+--- trunk.orig/util/ihpm.c
++++ trunk/util/ihpm.c
+@@ -2741,7 +2741,7 @@ int HpmfwupgGetTargetUpgCapabilities(voi
+ bitField.autRollbackOverride ? 'y' : 'n');
+ lprintf(LOG_NOTICE,"IPMC degraded...........[%c] ", pCtx->resp.GlobalCapabilities.
+ bitField.ipmcDegradedDurinUpg ? 'y' : 'n');
+- lprintf(LOG_NOTICE,"Defered activation......[%c] ", pCtx->resp.GlobalCapabilities.
++ lprintf(LOG_NOTICE,"Deferred activation.....[%c] ", pCtx->resp.GlobalCapabilities.
+ bitField.deferActivation ? 'y' : 'n');
+ lprintf(LOG_NOTICE,"Service affected........[%c] ", pCtx->resp.GlobalCapabilities.
+ bitField.servAffectDuringUpg ? 'y' : 'n');
+@@ -3337,12 +3337,12 @@ int HpmfwupgQueryRollbackStatus(void *in
+ if ( pCtx->resp.rollbackComp.ComponentBits.byte != 0 )
+ {
+ /* Rollback occured */
+- lprintf(LOG_NOTICE,"Rollback occured on component mask: 0x%02x",
++ lprintf(LOG_NOTICE,"Rollback occurred on component mask: 0x%02x",
+ pCtx->resp.rollbackComp.ComponentBits.byte);
+ }
+ else
+ {
+- lprintf(LOG_NOTICE,"No Firmware rollback occured");
++ lprintf(LOG_NOTICE,"No Firmware rollback occurred");
+ }
+ }
+ else if ( rsp->ccode == 0x81 )
+@@ -3476,7 +3476,7 @@ struct ipmi_rs * HpmfwupgSendCmd(void *i
+ {
+ /* keeping the inaccessTimeout to 60 seconds results in almost 2900 retries
+ * So if the target is not available it will be retrying the command for 2900
+- * times which is not effecient -So reducing the Timout to 5 seconds which is
++ * times which is not effecient -So reducing the Timeout to 5 seconds which is
+ * almost 200 retries if it continuously recieves 0xC3 as completion code.
+ */
+ inaccessTimeout = HPMFWUPG_DEFAULT_UPGRADE_TIMEOUT;
+@@ -3747,7 +3747,7 @@ static void HpmfwupgPrintUsage(void)
+ lprintf(LOG_NOTICE," component 0 - BOOT");
+ lprintf(LOG_NOTICE," component 1 - RTK");
+ lprintf(LOG_NOTICE,"upgrade <file> activate - Upgrade the firmware using a valid HPM.1 image <file>");
+- lprintf(LOG_NOTICE," If activate is specified, activate new firmware rigth");
++ lprintf(LOG_NOTICE," If activate is specified, activate new firmware right");
+ lprintf(LOG_NOTICE," away");
+ lprintf(LOG_NOTICE,"activate [norollback] - Activate the newly uploaded firmware");
+ lprintf(LOG_NOTICE,"targetcap - Get the target upgrade capabilities");
+Index: trunk/lib/lanplus/lanplus.c
+===================================================================
+--- trunk.orig/lib/lanplus/lanplus.c
++++ trunk/lib/lanplus/lanplus.c
+@@ -3819,7 +3819,7 @@ ipmi_lanplus_open(struct ipmi_intf * int
+ if (ipmi_get_auth_capabilities_cmd(intf, &auth_cap))
+ {
+ lprintf(LOG_INFO, "Error issuing Get Channel "
+- "Authentication Capabilies request");
++ "Authentication Capabilities request");
+ goto fail;
+ }
+ }
+Index: trunk/hpiutil/hpisel.c
+===================================================================
+--- trunk.orig/hpiutil/hpisel.c
++++ trunk/hpiutil/hpisel.c
+@@ -293,12 +293,12 @@ struct {
+ #define NCRITS 10
+ char * crit_int_str[NCRITS] = { /* Critical Interrupt descriptions */
+ /*00*/ "FP NMI ", /* Front Panel NMI */
+- /*01*/ "Bus Timout",
++ /*01*/ "Bus Timeout",
+ /*02*/ "IOch NMI ", /* IO channel check NMI */
+ /*03*/ "Soft NMI ",
+ /*04*/ "PCI PERR ",
+ /*05*/ "PCI SERR ",
+- /*06*/ "EISA Timout",
++ /*06*/ "EISA Timeout",
+ /*07*/ "Bus Warn ", /* Bus Correctable Error */
+ /*08*/ "Bus Error", /* Bus Uncorrectable Error */
+ /*09*/ "Fatal NMI" };
+Index: trunk/util/ievents.c
+===================================================================
+--- trunk.orig/util/ievents.c
++++ trunk/util/ievents.c
+@@ -275,12 +275,12 @@ static struct {
+ #define NCRITS 10
+ char * crit_int_str[NCRITS] = { /* Critical Interrupt descriptions */
+ /*00*/ "FP NMI ", /* Front Panel NMI */
+- /*01*/ "Bus Timout",
++ /*01*/ "Bus Timeout",
+ /*02*/ "IOch NMI ", /* IO channel check NMI */
+ /*03*/ "Soft NMI ",
+ /*04*/ "PCI PERR ",
+ /*05*/ "PCI SERR ",
+- /*06*/ "EISA Timout",
++ /*06*/ "EISA Timeout",
+ /*07*/ "Bus Warn ", /* Bus Correctable Error */
+ /*08*/ "Bus Error", /* Bus Uncorrectable Error */
+ /*09*/ "Fatal NMI" };
+Index: trunk/util/oem_dell.c
+===================================================================
+--- trunk.orig/util/oem_dell.c
++++ trunk/util/oem_dell.c
+@@ -5642,7 +5642,7 @@ char * get_dell_evt_desc(uchar *sel_rec,
+ if(code == 0x10)
+ {
+ if((data1 & 0x0f) == 0x03) {
+- snprintf(desc,SIZE_OF_DESC,"All Even Logging Dissabled");
++ snprintf(desc,SIZE_OF_DESC,"All Even Logging Disabled");
+ *psev = SEV_INFO;
+ }
+ }
diff --git a/debian/patches/0110-fix_malformed_messages.patch b/debian/patches/0110-fix_malformed_messages.patch
new file mode 100644
index 0000000..d9c744a
--- /dev/null
+++ b/debian/patches/0110-fix_malformed_messages.patch
@@ -0,0 +1,66 @@
+Description: do not abort if sensor command fails
+Origin: upstream
+Bug: https://github.com/arcress0/ipmiutil/issues/17
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1040349
+Forwarded: no
+Last-Update: 2023-07-09
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/util/isensor.c
+===================================================================
+--- trunk.orig/util/isensor.c
++++ trunk/util/isensor.c
+@@ -1332,13 +1332,14 @@ int GetSDR(int r_id, int *r_next, uchar
+ if (sresp < (thislen+2)) {
+ /* There are some SDRs that may report the wrong length, and
+ * return less bytes than they reported, so just truncate. */
++ fprintf(stderr,"SDR record %x is malformed, length %d is less than minimum %d\n",r_id,sresp,thislen+2);
+ if (fdebug) printf("sdr[%x] off=%d, expected %d, got %d\n",
+ r_id,off,thislen+2,sresp);
+ if (sresp >= 2) thislen = sresp - 2;
+ else thislen = 0;
+ reclen = off + thislen; /* truncate, stop reading */
+- fprintf(stderr,"SDR record %x is malformed, length %d is less than minimum %d\n",r_id,sresp,thislen+2);
+- rc = ERR_SDR_MALFORMED;
++ /* auto-corrected, so not a fatal error */
++ // rc = ERR_SDR_MALFORMED;
+ }
+ /* successful */
+ memcpy(&resp[off],&respchunk[2],thislen);
+Index: trunk/doc/ipmiutil.spec
+===================================================================
+--- trunk.orig/doc/ipmiutil.spec
++++ trunk/doc/ipmiutil.spec
+@@ -210,6 +210,10 @@ rm -rf %{buildroot}
+ vardir=%{_var}/lib/%{name}
+ scr_dir=%{_datadir}/%{name}
+
++if [ ! -f %{_datadir}/%{name}/ipmiutil.env ]; then
++ cp %{_datadir}/%{name}/ipmiutil.env.template %{_datadir}/%{name}/ipmiutil.env
++fi
++
+ # Install right scripts/service files no matter install or upgrade
+ %if 0%{?req_systemd}
+ %service_add_post ipmi_port.service ipmiutil_evt.service ipmiutil_asy.service ipmiutil_wdt.service
+@@ -217,9 +221,6 @@ scr_dir=%{_datadir}/%{name}
+ if [ -x /bin/systemctl ] && [ -d %{unit_dir} ]; then
+ # Replace if exists, append if not.
+ # Use # as the sed delimiter to prevent handling slash in the path.
+- if [ ! -f %{_datadir}/%{name}/ipmiutil.env ]; then
+- cp %{_datadir}/%{name}/ipmiutil.env.template %{_datadir}/%{name}/ipmiutil.env
+- fi
+ grep -q 'IINITDIR' %{_datadir}/%{name}/ipmiutil.env \
+ && sed -i 's#^IINITDIR=.*#IINITDIR=%{init_dir}#' %{_datadir}/%{name}/ipmiutil.env \
+ || echo "IINITDIR=%{init_dir}" >> %{_datadir}/%{name}/ipmiutil.env
+@@ -274,8 +275,9 @@ then
+ # Capture a snapshot of IPMI sensor data once now for later reuse.
+ sensorout=$vardir/sensor_out.txt
+ if [ ! -f $sensorout ]; then
+- %{_bindir}/ipmiutil sensor -q >$sensorout || :
+- if [ $? -ne 0 ]; then
++ IPMIret=1
++ %{_bindir}/ipmiutil sensor -q >$sensorout && IPMIret=0
++ if [ $IPMIret -ne 0 ]; then
+ # remove file if error, try again in ipmi_port on reboot.
+ rm -f $sensorout
+ fi
diff --git a/debian/patches/0600-typo-man.patch b/debian/patches/0600-typo-man.patch
new file mode 100644
index 0000000..bbaff1d
--- /dev/null
+++ b/debian/patches/0600-typo-man.patch
@@ -0,0 +1,66 @@
+Description: typo manpages
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2018-08-01
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/doc/iekanalyzer.8
+===================================================================
+--- trunk.orig/doc/iekanalyzer.8
++++ trunk/doc/iekanalyzer.8
+@@ -116,7 +116,7 @@ Display point to point physical connecti
+ AMC slot B2 topology:
+ Port 0 =====> On Carrier Device ID 0, Port 3
+ Port 2 =====> AMC slot B1, Port 2
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ From Carrier file: carrierfru
+ On Carrier Device ID 0 topology:
+ Port 0 =====> AMC slot B1, Port 4
+@@ -172,7 +172,7 @@ and an AMC module or between 2 AMC modul
+ Link Type: AMC.2 Ethernet
+ Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+ Link Group ID: 0 || Link Asym. Match: exact match
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ AMC slot B1 port 1 ==> On-Carrier Device 0 port 12
+ Matching Result
+ From On-Carrier Device ID 0
+@@ -185,7 +185,7 @@ and an AMC module or between 2 AMC modul
+ Link Type: AMC.2 Ethernet
+ Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+ Link Group ID: 0 || Link Asym. Match: exact match
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ On-Carrier Device vs AMC slot A2
+ AMC slot A2 port 0 ==> On-Carrier Device 0 port 3
+ Matching Result
+@@ -199,7 +199,7 @@ and an AMC module or between 2 AMC modul
+ Link Type: AMC.2 Ethernet
+ Link Type extension: 1000BASE-BX (SerDES Gigabit) Ethernet link
+ Link Group ID: 0 || Link Asym. Match: exact match
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ AMC slot B1 vs AMC slot A2
+ AMC slot A2 port 2 ==> AMC slot B1 port 2
+ Matching Result
+@@ -213,7 +213,7 @@ and an AMC module or between 2 AMC modul
+ Link Type: AMC.3 Storage
+ Link Type extension: Serial Attached SCSI (SAS/SATA)
+ Link Group ID: 0 || Link Asym. Match: FC or SAS interface {exact match}
+- *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
++ *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+ .TP
+ \fIunmatch\fP \fBxx=filename\fR \fBxx=filename\fR \fB...\fr
+ .br
+Index: trunk/doc/ifru.8
+===================================================================
+--- trunk.orig/doc/ifru.8
++++ trunk/doc/ifru.8
+@@ -1,6 +1,6 @@
+ .TH IFRU 8 "Version 1.4: 09 Sep 2010"
+ .SH NAME
+-ipmiutil_fru \- show Field Replacable Unit configuration data
++ipmiutil_fru \- show Field Replaceable Unit configuration data
+ .SH SYNOPSIS
+ .B "ipmiutil fru [-abcdeikmsvx -N node -U user -P/-R pswd -EFJTVYZ]"
+
diff --git a/debian/patches/0700-init.patch b/debian/patches/0700-init.patch
new file mode 100644
index 0000000..36250a6
--- /dev/null
+++ b/debian/patches/0700-init.patch
@@ -0,0 +1,234 @@
+Description: include lsb/init-functions
+Author: Jörg Frings-Fürst <debian@jff.email>
+Last-Update: 2022-10-02
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/scripts/ipmi_port.sh
+===================================================================
+--- trunk.orig/scripts/ipmi_port.sh
++++ trunk/scripts/ipmi_port.sh
+@@ -14,8 +14,8 @@
+ # Provides: ipmi_port
+ # Required-Start: $local_fs $network $remote_fs
+ # Required-Stop: $local_fs $network $remote_fs
+-# Default-Start: 3 4 5 3 4 5
+-# Default-Stop: 0 1 2 6 0 1 2 6
++# Default-Start: 2 3 4 5
++# Default-Stop: 0 1 6
+ # Short-Description: ipmi_port reserves the RMCP port from portmap
+ # Description: ipmi_port is used to reserve the RMCP port from portmap
+ ### END INIT INFO
+@@ -29,7 +29,7 @@ name=ipmi_port
+ progdir=/usr/sbin
+ prog="$progdir/$name"
+ lockfile=/var/lock/subsys/$name
+-portmap=/etc/init.d/portmap
++portmap=/etc/init.d/rpcbind
+ shardir=/usr/share
+ mibdir=$shardir/snmp/mibs
+ datadir=$shardir/ipmiutil
+@@ -40,6 +40,8 @@ threshout=${vardir}/thresh_out.txt
+ # This threshold script could be created by ipmiutil sensor -p ...
+ thresh="${vardir}/thresholds.sh"
+
++. /lib/lsb/init-functions
++
+ getpid () {
+ # This is messy if the parent script is same name as $1
+ p=`ps -ef |grep "$1" |grep -v grep |awk '{print $2}'`
+@@ -184,4 +186,3 @@ case "$1" in
+ esac
+
+ exit $?
+-
+Index: trunk/scripts/ipmiutil_asy
+===================================================================
+--- trunk.orig/scripts/ipmiutil_asy
++++ trunk/scripts/ipmiutil_asy
+@@ -13,8 +13,8 @@
+ # Provides: ipmiutil_asy
+ # Required-Start: $local_fs $remote_fs $syslog
+ # Required-Stop: $local_fs $remote_fs $syslog
+-# Default-Start: 3 4 5 3 4 5
+-# Default-Stop: 0 1 2 6 0 1 2 6
++# Default-Start: 2 3 4 5
++# Default-Stop: 0 1 6
+ # Short-Description: ipmiutil async bridge agent init script
+ # Description: Init script starts ipmiutil async bridge agent for remote reset
+ ### END INIT INFO
+@@ -25,6 +25,8 @@
+ #. /etc/init.d/functions
+ #fi
+
++. /lib/lsb/init-functions
++
+ name="ipmiutil_asy"
+ dname="ipmiutil_asy bridge agent"
+ getevtlog=/var/log/${name}.log
+@@ -152,4 +154,3 @@ case "$1" in
+ exit 2
+ esac
+ exit $?
+-
+Index: trunk/scripts/ipmiutil_wdt
+===================================================================
+--- trunk.orig/scripts/ipmiutil_wdt
++++ trunk/scripts/ipmiutil_wdt
+@@ -14,13 +14,15 @@
+ # Provides: ipmiutil_wdt
+ # Required-Start: $local_fs $remote_fs $syslog
+ # Required-Stop: $local_fs $remote_fs $syslog
+-# Default-Start: 3 4 5 3 4 5
+-# Default-Stop: 0 1 2 6 0 1 2 6
++# Default-Start: 2 3 4 5
++# Default-Stop: 0 1 6
+ # Short-Description: ipmiutil watchdog timer init script
+ # Description: Init script to enable and reset ipmiutil watchdog timer via cron
+ ### END INIT INFO
+ #
+
++. /lib/lsb/init-functions
++
+ name=ipmiutil_wdt
+ progn="/usr/bin/ipmiutil wdt"
+ wdtcron=/etc/cron.d/wdt
+@@ -123,10 +125,13 @@ case "$1" in
+ restart)
+ restart
+ ;;
++ force-reload)
++ restart
++ ;;
+ reload)
+ restart
+ ;;
+ *)
+- echo "Usage: $0 {start|stop|status|restart|reload}"
++ echo "Usage: $0 {start|stop|status|restart|force-reload|reload}"
+ exit 1
+ esac
+Index: trunk/scripts/ipmiutil_evt
+===================================================================
+--- trunk.orig/scripts/ipmiutil_evt
++++ trunk/scripts/ipmiutil_evt
+@@ -15,8 +15,8 @@
+ # Provides: ipmiutil_evt
+ # Required-Start: $local_fs $remote_fs $syslog
+ # Required-Stop: $local_fs $remote_fs $syslog
+-# Default-Start: 3 4 5 3 4 5
+-# Default-Stop: 0 1 2 6 0 1 2 6
++# Default-Start: 2 3 4 5
++# Default-Stop: 0 1 6
+ # Short-Description: ipmiutil event monitoring init script
+ # Description: Init script starts ipmiutil event monitoring service
+ ### END INIT INFO
+@@ -27,6 +27,8 @@
+ #. /etc/init.d/functions
+ #fi
+
++. /lib/lsb/init-functions
++
+ name="ipmiutil_evt"
+ getevtlog=/var/log/$name.log
+ lockfile=/var/lock/subsys/$name
+@@ -40,6 +42,7 @@ getpid () {
+ echo $p
+ }
+
++
+ start()
+ {
+ echo -n "Starting $name: "
+@@ -155,4 +158,3 @@ case "$1" in
+ exit 2
+ esac
+ exit $?
+-
+Index: trunk/scripts/ipmi_info
+===================================================================
+--- trunk.orig/scripts/ipmi_info
++++ trunk/scripts/ipmi_info
+@@ -11,8 +11,8 @@
+ # Provides: ipmi_info
+ # Required-Start: $local_fs $network $remote_fs
+ # Required-Stop: $local_fs $network $remote_fs
+-# Default-Start:
+-# Default-Stop:
++# Default-Start: 2 3 4 5
++# Default-Stop: 0 1 6
+ # Short-Description: ipmi_info saves OS info to the IPMI system info
+ # Description: ipmi_info saves OS info to the IPMI system info
+ ### END INIT INFO
+@@ -21,6 +21,8 @@ name=ipmi_info
+ iuprog=/usr/bin/ipmiutil
+ tmp=/tmp/ipmi_info.tmp
+
++. /lib/lsb/init-functions
++
+ getosver() {
+ if [ -f /etc/os-release ]; then
+ . /etc/os-release
+@@ -121,4 +123,3 @@ case "$1" in
+ esac
+
+ exit $?
+-
+Index: trunk/scripts/ipmiutil_asy.service
+===================================================================
+--- trunk.orig/scripts/ipmiutil_asy.service
++++ trunk/scripts/ipmiutil_asy.service
+@@ -11,4 +11,3 @@ ExecStart=/usr/bin/ipmiutil getevt -a -b
+
+ [Install]
+ WantedBy=multi-user.target
+-
+Index: trunk/scripts/ipmiutil_evt.service
+===================================================================
+--- trunk.orig/scripts/ipmiutil_evt.service
++++ trunk/scripts/ipmiutil_evt.service
+@@ -11,5 +11,3 @@ ExecStart=/usr/bin/ipmiutil getevt $IPMI
+
+ [Install]
+ WantedBy=multi-user.target
+-
+-
+Index: trunk/scripts/ipmiutil_wdt.service
+===================================================================
+--- trunk.orig/scripts/ipmiutil_wdt.service
++++ trunk/scripts/ipmiutil_wdt.service
+@@ -10,5 +10,3 @@ RemainAfterExit=1
+
+ [Install]
+ WantedBy=multi-user.target
+-
+-
+Index: trunk/scripts/ipmi_port.service
+===================================================================
+--- trunk.orig/scripts/ipmi_port.service
++++ trunk/scripts/ipmi_port.service
+@@ -11,5 +11,3 @@ ExecStart=-/usr/sbin/ipmi_port -b
+
+ [Install]
+ WantedBy=multi-user.target
+-
+-
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac
++++ trunk/configure.ac
+@@ -422,11 +422,11 @@ else
+ MD2_CFLAGS="-DSKIP_MD2"
+ init0=/etc/rc.d/init.d
+ fi
+- if test $isredhat -eq 0 ; then
++# if test $isredhat -eq 0 ; then
+ # set default start/stop for init scripts
+- sed -i 's/# Default-Start:/# Default-Start: 3 4 5/' $init_scripts
+- sed -i 's/# Default-Stop:/# Default-Stop: 0 1 2 6/' $init_scripts
+- fi
++# sed -i 's/# Default-Start:/# Default-Start: 3 4 5/' $init_scripts
++# sed -i 's/# Default-Stop:/# Default-Stop: 0 1 2 6/' $init_scripts
++# fi
+ # The openssl rpm might not be installed
+ sslver=""
+ which rpm >/dev/null 2>&1
diff --git a/debian/patches/0705-crontab.patch b/debian/patches/0705-crontab.patch
new file mode 100644
index 0000000..3099a15
--- /dev/null
+++ b/debian/patches/0705-crontab.patch
@@ -0,0 +1,20 @@
+Description: Prevent watchdog to send minutly emails and log entries
+Author: Harry Coin <hcoin@quietfountain.com>
+Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/ipmiutil/+bug/1535408
+Last-Update: 2022-10-24
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/scripts/ipmiutil_wdt
+===================================================================
+--- trunk.orig/scripts/ipmiutil_wdt
++++ trunk/scripts/ipmiutil_wdt
+@@ -51,7 +51,8 @@ start() {
+ if [ $RETVAL -eq 0 ]; then
+ # restart the watchdog every 60 seconds via /etc/cron.d
+ cat - <<%%% >$wdtcron
+-* * * * * root $progn -r >/dev/null
++MAILTO=''
++* * * * * root $progn -r >/dev/null 2>&1
+ %%%
+ # make crond re-read the /etc/cron.d
+ $restart_cron >>$wdtlog
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..b8ba109
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,5 @@
+0110-fix_malformed_messages.patch
+0105-typo.patch
+0700-init.patch
+0600-typo-man.patch
+0705-crontab.patch