summaryrefslogtreecommitdiff
path: root/sample/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2019-11-29 11:26:57 +0100
committerJörg Frings-Fürst <debian@jff.email>2019-11-29 11:26:57 +0100
commit7f4e90f2759d6a15812172ee19f3ad5b58940beb (patch)
tree5f90c63b8ba73f4ecd23d6e642c1ab34dccea033 /sample/Makefile.am
parent68d1ec60c90d27c511d51ce0bef44b132a7ddf11 (diff)
parent7e149a97d276ce3b4c5e34f965766c8e40e03fef (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'sample/Makefile.am')
-rw-r--r--sample/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/sample/Makefile.am b/sample/Makefile.am
index 320afcf..22a4989 100644
--- a/sample/Makefile.am
+++ b/sample/Makefile.am
@@ -6,7 +6,11 @@ LDADD = $(lib_onig)
AM_LDFLAGS = -L$(prefix)/lib
AM_CPPFLAGS = -I$(top_srcdir)/src
-TESTS = encode listcap names posix simple sql syntax user_property callout echo count bug_fix
+if ENABLE_POSIX_API
+TESTS = encode listcap names posix simple sql syntax user_property callout echo count bug_fix regset
+else
+TESTS = encode listcap names simple sql syntax user_property callout echo count bug_fix regset
+endif
check_PROGRAMS = $(TESTS)
@@ -22,6 +26,7 @@ callout_SOURCES = callout.c
echo_SOURCES = echo.c
count_SOURCES = count.c
bug_fix = bug_fix.c
+regset_SOURCES = regset.c
sampledir = .
@@ -29,7 +34,9 @@ test: $(TESTS)
$(sampledir)/encode
$(sampledir)/listcap
$(sampledir)/names
+if ENABLE_POSIX_API
$(sampledir)/posix
+endif
$(sampledir)/simple
$(sampledir)/sql
$(sampledir)/syntax
@@ -38,3 +45,4 @@ test: $(TESTS)
$(sampledir)/echo
$(sampledir)/count
$(sampledir)/bug_fix
+ $(sampledir)/regset