summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6559a77..2dde7d6 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -9,7 +9,7 @@ TESTS = test_utf8 testc testp testcu
check_PROGRAMS = test_utf8 testc testp testcu
-test: test_utf8 testc testp testcu
+test: test_uchar test_utf8 testc testp testcu
@echo "[Oniguruma API, UTF-8 check]"
@./test_utf8 | grep RESULT
@echo "[Oniguruma API, ASCII/EUC-JP check]"
@@ -19,6 +19,11 @@ test: test_utf8 testc testp testcu
@echo "[Oniguruma API, UTF-16 check]"
@./testcu | grep RESULT
+test_uchar:
+ @echo "[UChar in oniguruma.h check]"
+ @grep "\(^\|[^g]\)UChar" $(top_srcdir)/src/oniguruma.h
+ @echo ""
+
test_utf8_SOURCES = test_utf8.c
test_utf8_LDADD = $(lib_onig)