summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..b34aa21f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE=1
+
+# hardening
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+include /usr/share/dpkg/default.mk
+
+ifneq ($(findstring $(DEB_BUILD_ARCH), mips mipsel),)
+ CFLAGS += -mplt
+endif
+
+DEB_CONFIGURE_EXTRA_FLAGS := --disable-Werror \
+ --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH)
+DEB_DH_INSTALL_ARGS := --sourcedir=$(DEB_DESTDIR)
+
+DEB_MAKE_CHECK_TARGET = check
+
+VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-/')
+
+%:
+ dh $@
+
+override_dh_makeshlibs:
+ dh_makeshlibs
+ dpkg-gensymbols -v$(DEB_VERSION_UPSTREAM) -plibunistring5