summaryrefslogtreecommitdiff
path: root/frontend/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2024-03-03 09:55:03 +0100
committerJörg Frings-Fürst <debian@jff.email>2024-03-03 09:55:03 +0100
commit23c348d62ab9f0a902189c70921310a5f856852c (patch)
tree08c40dc8b180b31f504945e8da3e3ea3950e4145 /frontend/Makefile.am
parent2938695ca4c9bca7834817465662e31570f6d32f (diff)
parent44916ca6d75e0b5f258a098a50d659f31c6625fd (diff)
Update upstream source from tag 'upstream/1.3.0'
Update to upstream version '1.3.0' with Debian dir ab14a3d39c8a7f8e08536efd939bb78110db77f3
Diffstat (limited to 'frontend/Makefile.am')
-rw-r--r--frontend/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/frontend/Makefile.am b/frontend/Makefile.am
index 9b92645..8573aba 100644
--- a/frontend/Makefile.am
+++ b/frontend/Makefile.am
@@ -44,5 +44,20 @@ tstbackend_LDADD += -lstdc++
endif
endif
-clean-local:
- rm -f test tstbackend
+BUILT_SOURCES = saned@.service saned.xinetd.conf
+
+EXTRA_DIST = saned.socket saned@.service.in saned.xinetd.conf.in
+
+CLEANFILES = $(EXTRA_PROGRAMS) $(BUILT_SOURCES)
+
+SUFFIXES = .in
+.in:
+ $(AM_V_GEN)
+ @if $(AM_V_P); then echo Generating $@ from $^; fi
+ @sed -e 's|@DATADIR@|$(datadir)|g' \
+ -e 's|@CONFIGDIR@|$(configdir)|g' \
+ -e 's|@DOCDIR@|$(docdir)|g' \
+ -e 's|@LIBDIR@|$(libdir)/sane|g' \
+ -e 's|@BINDIR@|$(bindir)|g' \
+ -e 's|@SBINDIR@|$(sbindir)|g' \
+ -e 's|@PACKAGEVERSION@|$(PACKAGE_VERSION)|g' $? > $@