Description: Use depth from session
Author: Jörg Frings-Fürst <debian@jff.email>
Last-Update: 2020-04-01 
Index: trunk/backend/genesys/low.cpp
===================================================================
--- trunk.orig/backend/genesys/low.cpp
+++ trunk/backend/genesys/low.cpp
@@ -539,7 +539,7 @@ Image read_unshuffled_image_from_scanner
     }
 
 #ifdef WORDS_BIGENDIAN
-    if (depth == 16) {
+    if (session.params.depth == 16) {
         dev->pipeline.push_node<ImagePipelineNodeSwap16BitEndian>();
     }
 #endif