Description: Make build reproducible.
Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
Last-Update: 2015-05-21
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
Index: trunk/tools/sane-desc.c
===================================================================
--- trunk.orig/tools/sane-desc.c
+++ trunk/tools/sane-desc.c
@@ -2816,8 +2816,10 @@ html_print_footer (void)
      "<address>\n"
      "<a href=\"http://www.sane-project.org/imprint.html\"\n"
      ">Contact</a>\n" "</address>\n" "<font size=-1>\n");
-  printf ("This page was last updated on %s by sane-desc %s from %s\n",
-	  asctime (localtime (&current_time)), SANE_DESC_VERSION, PACKAGE_STRING);
+/*  printf ("This page was last updated on %s by sane-desc %s from %s\n",
+	  asctime (localtime (&current_time)), SANE_DESC_VERSION, PACKAGE_STRING); */
+  printf ("This page was last updated by sane-desc %s from %s\n",
+	  SANE_DESC_VERSION, PACKAGE_STRING);
   printf ("</font>\n");
   printf ("</body> </html>\n");
 }
@@ -3656,8 +3658,8 @@ print_udevhwdb_header (void)
 {
   time_t current_time = time (0);
   printf ("# This file was automatically created based on description files (*.desc)\n"
-	  "# by sane-desc %s from %s on %s",
-	  SANE_DESC_VERSION, PACKAGE_STRING, asctime (localtime (&current_time)));
+	  "# by sane-desc %s from %s\n",
+	  SANE_DESC_VERSION, PACKAGE_STRING );
 
   printf
     ("#\n"
Index: trunk/Makefile.in
===================================================================
--- trunk.orig/Makefile.in
+++ trunk/Makefile.in
@@ -254,7 +254,7 @@ DLLTOOL = @DLLTOOL@
 DL_LIBS = @DL_LIBS@
 DSYMUTIL = @DSYMUTIL@
 DUMPBIN = @DUMPBIN@
-DVIPS = @DVIPS@
+DVIPS = @DVIPS@ -N
 DYNAMIC_FLAG = @DYNAMIC_FLAG@
 ECHO_C = @ECHO_C@
 ECHO_N = @ECHO_N@
@@ -276,7 +276,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
 INSTALL_SCRIPT = @INSTALL_SCRIPT@
 INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
 JPEG_LIBS = @JPEG_LIBS@
-LATEX = @LATEX@
+LATEX = @LATEX@ --output-comment=""
 LD = @LD@
 LDFLAGS = @LDFLAGS@
 LIBOBJS = @LIBOBJS@
Index: trunk/doc/Makefile.in
===================================================================
--- trunk.orig/doc/Makefile.in
+++ trunk/doc/Makefile.in
@@ -190,7 +190,7 @@ DLLTOOL = @DLLTOOL@
 DL_LIBS = @DL_LIBS@
 DSYMUTIL = @DSYMUTIL@
 DUMPBIN = @DUMPBIN@
-DVIPS = @DVIPS@
+DVIPS = @DVIPS@ -N
 DYNAMIC_FLAG = @DYNAMIC_FLAG@
 ECHO_C = @ECHO_C@
 ECHO_N = @ECHO_N@
@@ -212,7 +212,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
 INSTALL_SCRIPT = @INSTALL_SCRIPT@
 INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
 JPEG_LIBS = @JPEG_LIBS@
-LATEX = TEXINPUTS="$(srcdir):$$TEXINPUTS" @LATEX@
+LATEX = TEXINPUTS="$(srcdir):$$TEXINPUTS" @LATEX@ --output-comment=""
 LD = @LD@
 LDFLAGS = @LDFLAGS@
 LIBOBJS = @LIBOBJS@
Index: trunk/testsuite/tools/data/html-backends-split.ref
===================================================================
--- trunk.orig/testsuite/tools/data/html-backends-split.ref
+++ trunk/testsuite/tools/data/html-backends-split.ref
@@ -16496,7 +16496,6 @@ Grandtek Scopecam
 >Contact</a>
 </address>
 <font size=-1>
-This page was last updated on Wed Jul 31 07:52:48 2013
- by sane-desc 3.5 from sane-backends 1.0.24git
+This page was last updated by sane-desc 3.5 from sane-backends 1.0.25
 </font>
 </body> </html>
Index: trunk/testsuite/tools/data/html-mfgs.ref
===================================================================
--- trunk.orig/testsuite/tools/data/html-mfgs.ref
+++ trunk/testsuite/tools/data/html-mfgs.ref
@@ -23910,7 +23910,6 @@ qcam<br>(unmaintained)
 >Contact</a>
 </address>
 <font size=-1>
-This page was last updated on Wed Jul 31 07:52:48 2013
- by sane-desc 3.5 from sane-backends 1.0.24git
+This page was last updated by sane-desc 3.5 from sane-backends 1.0.25
 </font>
 </body> </html>
Index: trunk/testsuite/tools/data/udev.ref
===================================================================
--- trunk.orig/testsuite/tools/data/udev.ref
+++ trunk/testsuite/tools/data/udev.ref
@@ -1,5 +1,5 @@
 # This file was automatically created based on description files (*.desc)
-# by sane-desc 3.5 from sane-backends 1.0.24git on Wed Jul 31 07:52:48 2013
+# by sane-desc 3.5 from sane-backends 1.0.25
 #
 # udev rules file for supported USB and SCSI devices
 #
Index: trunk/testsuite/tools/data/udev+acl.ref
===================================================================
--- trunk.orig/testsuite/tools/data/udev+acl.ref
+++ trunk/testsuite/tools/data/udev+acl.ref
@@ -1,5 +1,5 @@
 # This file was automatically created based on description files (*.desc)
-# by sane-desc 3.5 from sane-backends 1.0.24git on Wed Jul 31 07:52:49 2013
+# by sane-desc 3.5 from sane-backends 1.0.25
 #
 # udev rules file for supported USB and SCSI devices
 #
Index: trunk/testsuite/tools/data/udev+hwdb.ref
===================================================================
--- trunk.orig/testsuite/tools/data/udev+hwdb.ref
+++ trunk/testsuite/tools/data/udev+hwdb.ref
@@ -1,5 +1,5 @@
 # This file was automatically created based on description files (*.desc)
-# by sane-desc 3.5 from sane-backends 1.0.24git on Thu Aug  1 18:50:15 2013
+# by sane-desc 3.5 from sane-backends 1.0.25
 #
 # udev rules file for supported USB and SCSI devices
 #