summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-06-28 12:27:50 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-06-28 12:27:50 +0200
commit84bcd0b97df992d9e633cf3c3b9382f202e4f754 (patch)
tree8bae1f453a0723e74b7f6b6e349775475ba730e1 /autogen.sh
parent21b9155ede6470d02c0aa026131532092e2db8d0 (diff)
parentc2b991e03eeccb2c87efb12455bb674caa083f15 (diff)
Merge tag 'upstream/3.17.3'
Upstream version 3.17.3
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh43
1 files changed, 29 insertions, 14 deletions
diff --git a/autogen.sh b/autogen.sh
index 8f3fc0d..34bf0c3 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -1,21 +1,36 @@
#!/bin/sh
# Run this to generate all the initial makefiles, etc.
-
srcdir=`dirname $0`
test -z "$srcdir" && srcdir=.
-PKG_NAME="simple_scan"
-REQUIRED_AUTOMAKE_VERSION=1.7
-
-(test -f $srcdir/configure.ac \
- && test -d $srcdir/src) || {
- echo -n "**Error**: Directory "\`$srcdir\'" does not look like the"
- echo " top-level simple-scan directory"
- exit 1
+(test -f $srcdir/configure.ac) || {
+ echo "**Error**: Directory "\`$srcdir\'" does not look like the top-level project directory"
+ exit 1
}
-which gnome-autogen.sh || {
- echo "You need to install gnome-common from the GNOME CVS"
- exit 1
-}
-USE_GNOME2_MACROS=1 USE_COMMON_DOC_BUILD=yes . gnome-autogen.sh
+PKG_NAME=`autoconf --trace 'AC_INIT:$1' "$srcdir/configure.ac"`
+
+if [ "$#" = 0 -a "x$NOCONFIGURE" = "x" ]; then
+ echo "**Warning**: I am going to run \`configure' with no arguments." >&2
+ echo "If you wish to pass any to it, please specify them on the" >&2
+ echo \`$0\'" command line." >&2
+ echo "" >&2
+fi
+
+set -x
+aclocal --install || exit 1
+intltoolize --force --copy --automake || exit 1
+autoreconf --verbose --force --install -Wno-portability || exit 1
+set +x
+
+if [ "$NOCONFIGURE" = "" ]; then
+ set -x
+ $srcdir/configure "$@" || exit 1
+ set +x
+
+ if [ "$1" = "--help" ]; then exit 0 else
+ echo "Now type \`make\' to compile $PKG_NAME" || exit 1
+ fi
+else
+ echo "Skipping configure process."
+fi