summaryrefslogtreecommitdiff
path: root/debian/patches/20-lpi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/20-lpi.patch')
-rw-r--r--debian/patches/20-lpi.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/debian/patches/20-lpi.patch b/debian/patches/20-lpi.patch
new file mode 100644
index 0000000..ca85979
--- /dev/null
+++ b/debian/patches/20-lpi.patch
@@ -0,0 +1,40 @@
+Origin: Ubuntu
+Description: Add launchpad-integration support.
+---
+ configure.ac | 1 +
+ src/Makefile.am | 1 +
+ src/ui.vala | 3 +++
+ 3 files changed, 5 insertions(+)
+
+--- simple-scan.orig/configure.ac
++++ simple-scan/configure.ac
+@@ -32,6 +32,7 @@ PKG_CHECK_MODULES(SIMPLE_SCAN, [
+ cairo
+ gdk-pixbuf-2.0
+ gudev-1.0
++ launchpad-integration-3.0
+ ])
+
+ PKG_CHECK_MODULES(COLORD, [
+--- simple-scan.orig/src/Makefile.am
++++ simple-scan/src/Makefile.am
+@@ -15,6 +15,7 @@ simple_scan_SOURCES = \
+
+ simple_scan_VALAFLAGS = \
+ --pkg=zlib \
++ --pkg=launchpad-integration-3.0 \
+ --pkg=gudev-1.0 \
+ --pkg=gio-2.0 \
+ --pkg=gtk+-3.0
+--- simple-scan.orig/src/ui.vala
++++ simple-scan/src/ui.vala
+@@ -1267,6 +1267,9 @@ public class SimpleScan
+ }
+ builder.connect_signals (this);
+
++ LaunchpadIntegration.set_sourcepackagename ("simple-scan");
++ LaunchpadIntegration.add_items ((Gtk.Widget) builder.get_object ("help_menu"), 1, true, true);
++
+ window = (Gtk.Window) builder.get_object ("simple_scan_window");
+ main_vbox = (Gtk.VBox) builder.get_object ("main_vbox");
+ page_move_left_menuitem = (Gtk.MenuItem) builder.get_object ("page_move_left_menuitem");