summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0005-zlib.patch28
-rw-r--r--debian/patches/0010-metadata.patch18
-rw-r--r--debian/patches/0015-xdg-email.patch18
-rw-r--r--debian/patches/0100-typos.patch18
-rw-r--r--debian/patches/series4
5 files changed, 86 insertions, 0 deletions
diff --git a/debian/patches/0005-zlib.patch b/debian/patches/0005-zlib.patch
new file mode 100644
index 0000000..3e1fb0a
--- /dev/null
+++ b/debian/patches/0005-zlib.patch
@@ -0,0 +1,28 @@
+Description: add zlib
+Last-Update: 2015-01-19
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac
++++ trunk/configure.ac
+@@ -71,6 +71,7 @@ AM_CONDITIONAL(HAVE_PACKAGEKIT, test $ha
+
+ AC_CHECK_HEADERS([sane/sane.h],[],[AC_MSG_ERROR([SANE not found])])
+ AC_CHECK_HEADERS([sane/saneopts.h],[],[AC_MSG_ERROR([SANE not found])])
++AC_CHECK_HEADERS([zlib.h],[],[AC_MSG_ERROR([ZLib not found])])
+
+ dnl ###########################################################################
+ dnl Documentation
+Index: trunk/src/Makefile.am
+===================================================================
+--- trunk.orig/src/Makefile.am
++++ trunk/src/Makefile.am
+@@ -57,6 +57,7 @@ simple_scan_LDADD = \
+ $(COLORD_LIBS) \
+ $(PACKAGEKIT_LIBS) \
+ -lsane \
++ -lz \
+ -lm
+
+ CLEANFILES = \
diff --git a/debian/patches/0010-metadata.patch b/debian/patches/0010-metadata.patch
new file mode 100644
index 0000000..7277159
--- /dev/null
+++ b/debian/patches/0010-metadata.patch
@@ -0,0 +1,18 @@
+Description: Install metadate into /usr/share/metainfo/
+Author: Jörg Frings-Fürst <debian@jff.email>
+Last-Update: 2017-11-12
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/data/meson.build
+===================================================================
+--- trunk.orig/data/meson.build
++++ trunk/data/meson.build
+@@ -23,7 +23,7 @@ i18n.merge_file ('appdata-file',
+ input: 'simple-scan.appdata.xml.in',
+ output: 'simple-scan.appdata.xml',
+ install: true,
+- install_dir: join_paths (datadir, 'appdata'),
++ install_dir: join_paths (datadir, 'metainfo'),
+ po_dir: '../po')
+
+ install_man ('simple-scan.1')
diff --git a/debian/patches/0015-xdg-email.patch b/debian/patches/0015-xdg-email.patch
new file mode 100644
index 0000000..a86c354
--- /dev/null
+++ b/debian/patches/0015-xdg-email.patch
@@ -0,0 +1,18 @@
+Description: Add space between xdg-email ans parameter
+Author: Jörg Frings-Fürst <debian@jff.email>
+Last-Update: 2018-01-13
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/src/app-window.vala
+===================================================================
+--- trunk.orig/src/app-window.vala
++++ trunk/src/app-window.vala
+@@ -1193,7 +1193,7 @@ public class AppWindow : Gtk.Application
+ yield book.save_async (type, settings.get_int ("jpeg-quality"), file, null, null);
+ var command_line = "xdg-email";
+ if (type == "pdf")
+- command_line += "--attach %s".printf (file.get_path ());
++ command_line += " --attach %s".printf (file.get_path ());
+ else
+ {
+ for (var i = 0; i < book.n_pages; i++) {
diff --git a/debian/patches/0100-typos.patch b/debian/patches/0100-typos.patch
new file mode 100644
index 0000000..0f63a81
--- /dev/null
+++ b/debian/patches/0100-typos.patch
@@ -0,0 +1,18 @@
+Description: Typos
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 206-04-10
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/src/autosave-manager.vala
+===================================================================
+--- trunk.orig/src/autosave-manager.vala
++++ trunk/src/autosave-manager.vala
+@@ -74,7 +74,7 @@ public class AutosaveManager
+ catch (Error e)
+ {
+ if (!(e is FileError.NOENT))
+- warning ("Could not load autosave infomation; not restoring any autosaves: %s", e.message);
++ warning ("Could not load autosave information; not restoring any autosaves: %s", e.message);
+ return;
+ }
+ var pages = get_value (file, "simple-scan", "pages");
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..283f89a
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,4 @@
+#0100-typos.patch
+#0005-zlib.patch
+0015-xdg-email.patch
+0010-metadata.patch