summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules36
1 files changed, 36 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a781c17
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,36 @@
+#!/usr/bin/make -f
+
+DISTRIBUTION = $(shell lsb_release -i | cut -f2 -d':' | tr -d '\t')
+LDFLAGS+=-Wl,--as-needed
+
+%:
+ dh $@ --with=quilt
+
+override_dh_quilt_unpatch:
+ dh_quilt_unpatch
+ifeq ("$(DISTRIBUTION)", "Ubuntu")
+ if test -e debian/patches/series.old; then \
+ mv debian/patches/series.old debian/patches/series ;\
+ fi
+endif
+
+override_dh_quilt_patch:
+ifeq ("$(DISTRIBUTION)", "Ubuntu")
+ cp debian/patches/series debian/patches/series.old
+ echo 20-lpi.patch >> debian/patches/series
+endif
+ dh_quilt_patch
+
+# Fixes FTBFS
+override_dh_auto_test:
+
+# Autoreconf due to 01_lpi.patch
+override_dh_auto_configure:
+ [ -e gnome-doc-utils.make ] || \
+ ln -s /usr/share/gnome-doc-utils/gnome-doc-utils.make
+ autoreconf -f -i -s
+ dh_auto_configure
+
+override_dh_auto_build:
+ cd po; intltool-update -p
+ dh_auto_build