summaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:36 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:36 +0200
commitb6bd52cd7330a90fc0e44dbe6022551a8dd768a1 (patch)
tree9804282102f8c40d27407b9c94119b35eeb5013c /app/CMakeLists.txt
parentc9d0740841fbe0539e42e66d3865672bfcd3ac02 (diff)
parenta14a7a0ccc9de76aeab0b2e4bbf58f1a79deedc2 (diff)
Update upstream source from tag 'upstream/5.3.0GA'
Update to upstream version '5.3.0GA' with Debian dir dfd14d63b0238e276ade6f54dd9100325df5b2f9
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt33
1 files changed, 18 insertions, 15 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 72ca170..33e105a 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -1,20 +1,23 @@
-# "bin/i18n.h" is widely used
-INCLUDE_DIRECTORIES(bin)
-include_directories(dynstring)
-include_directories(cornu)
-include_directories(libzip)
+
+
# Setup the rest of the build ...
+add_subdirectory(tools)
+add_subdirectory(help)
+add_subdirectory(bin)
+add_subdirectory(cornu)
add_subdirectory(dynstring)
-ADD_SUBDIRECTORY(wlib)
-ADD_SUBDIRECTORY(tools)
-ADD_SUBDIRECTORY(help)
-ADD_SUBDIRECTORY(doc)
-ADD_SUBDIRECTORY(bin)
-ADD_SUBDIRECTORY(lib)
-ADD_SUBDIRECTORY(cornu)
+add_subdirectory(cJSON)
+add_subdirectory(wlib)
+add_subdirectory(doc)
+add_subdirectory(lib)
+
+# i18n can be found here
+include_directories(
+ ${xtrkcad-lib_SOURCE_DIR}
+)
-IF(XTRKCAD_USE_GETTEXT)
- ADD_SUBDIRECTORY(i18n)
-ENDIF(XTRKCAD_USE_GETTEXT) \ No newline at end of file
+if(XTRKCAD_USE_GETTEXT)
+ add_subdirectory(i18n)
+endif() \ No newline at end of file