summaryrefslogtreecommitdiff
path: root/app/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:30 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:30 +0200
commita14a7a0ccc9de76aeab0b2e4bbf58f1a79deedc2 (patch)
treee469179df67a0e0db49161a43cbf8076a189f6f4 /app/tools/CMakeLists.txt
parent5d2c2b27a6323e2666378b986129b2a7c2c39e5c (diff)
New upstream version 5.3.0GAupstream/5.3.0GAupstream
Diffstat (limited to 'app/tools/CMakeLists.txt')
-rw-r--r--app/tools/CMakeLists.txt13
1 files changed, 4 insertions, 9 deletions
diff --git a/app/tools/CMakeLists.txt b/app/tools/CMakeLists.txt
index befe170..433d464 100644
--- a/app/tools/CMakeLists.txt
+++ b/app/tools/CMakeLists.txt
@@ -1,15 +1,10 @@
-set ( sources listxtp.c )
+add_executable(listxtp listxtp.c)
+set_target_properties(listxtp PROPERTIES FOLDER "Param Files")
if (WIN32)
- set ( sources
- ${sources}
- dirent.c)
-
- include_directories( before ${CMAKE_CURRENT_SOURCE_DIR})
+ target_sources(listxtp PRIVATE dirent.c )
endif ()
-
-add_executable( listxtp ${sources})
add_subdirectory(halibut)
-
+add_subdirectory(pngtoxpm)