summaryrefslogtreecommitdiff
path: root/app/tools/halibut/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:49 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:49 +0200
commit8dc8048d2cd4996825470bbfcb1e09e2a2630035 (patch)
tree9804282102f8c40d27407b9c94119b35eeb5013c /app/tools/halibut/CMakeLists.txt
parentc9d0740841fbe0539e42e66d3865672bfcd3ac02 (diff)
parentb6bd52cd7330a90fc0e44dbe6022551a8dd768a1 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'app/tools/halibut/CMakeLists.txt')
-rw-r--r--app/tools/halibut/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/app/tools/halibut/CMakeLists.txt b/app/tools/halibut/CMakeLists.txt
index ec7d74b..a4ddc75 100644
--- a/app/tools/halibut/CMakeLists.txt
+++ b/app/tools/halibut/CMakeLists.txt
@@ -1,4 +1,5 @@
-SET(SOURCES
+
+add_executable(halibut
biblio.c
bk_html.c
contents.c
@@ -22,11 +23,13 @@ SET(SOURCES
ustring.c
version.c
wcwidth.c
- )
+)
-INCLUDE_DIRECTORIES(charset)
-ADD_EXECUTABLE(halibut ${SOURCES})
-TARGET_LINK_LIBRARIES(halibut xtrkcad-charset)
+set_target_properties(
+ halibut
+ PROPERTIES FOLDER HelpDocs
+)
+target_link_libraries(halibut xtrkcad-charset)
-ADD_SUBDIRECTORY(charset)
+add_subdirectory(charset)