summaryrefslogtreecommitdiff
path: root/app/tools/halibut/charset/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:49 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:49 +0200
commit8dc8048d2cd4996825470bbfcb1e09e2a2630035 (patch)
tree9804282102f8c40d27407b9c94119b35eeb5013c /app/tools/halibut/charset/CMakeLists.txt
parentc9d0740841fbe0539e42e66d3865672bfcd3ac02 (diff)
parentb6bd52cd7330a90fc0e44dbe6022551a8dd768a1 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'app/tools/halibut/charset/CMakeLists.txt')
-rw-r--r--app/tools/halibut/charset/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/app/tools/halibut/charset/CMakeLists.txt b/app/tools/halibut/charset/CMakeLists.txt
index 86521b8..684c70e 100644
--- a/app/tools/halibut/charset/CMakeLists.txt
+++ b/app/tools/halibut/charset/CMakeLists.txt
@@ -1,4 +1,7 @@
-SET(SOURCES
+#
+# Character set conversion library as required for halibut
+
+add_library(xtrkcad-charset
big5enc.c
big5set.c
charset.h
@@ -29,10 +32,11 @@ SET(SOURCES
utf16.c
utf7.c
utf8.c
- xenc.c
- )
-
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+ xenc.c)
-ADD_LIBRARY(xtrkcad-charset ${SOURCES})
+set_target_properties(
+ xtrkcad-charset
+ PROPERTIES FOLDER HelpDocs
+ )
+ target_include_directories(xtrkcad-charset PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})