summaryrefslogtreecommitdiff
path: root/app/cJSON/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/cJSON/CMakeLists.txt')
-rw-r--r--app/cJSON/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/app/cJSON/CMakeLists.txt b/app/cJSON/CMakeLists.txt
new file mode 100644
index 0000000..d4abca3
--- /dev/null
+++ b/app/cJSON/CMakeLists.txt
@@ -0,0 +1,13 @@
+#
+# build the cJSON object library
+
+add_library( cJSON "")
+
+target_sources(cJSON
+ PRIVATE
+ cJSON.c
+ PUBLIC
+ cJSON.h
+)
+
+target_include_directories(cJSON PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}) \ No newline at end of file