summaryrefslogtreecommitdiff
path: root/app/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/tools/CMakeLists.txt')
-rw-r--r--app/tools/CMakeLists.txt13
1 files changed, 4 insertions, 9 deletions
diff --git a/app/tools/CMakeLists.txt b/app/tools/CMakeLists.txt
index befe170..433d464 100644
--- a/app/tools/CMakeLists.txt
+++ b/app/tools/CMakeLists.txt
@@ -1,15 +1,10 @@
-set ( sources listxtp.c )
+add_executable(listxtp listxtp.c)
+set_target_properties(listxtp PROPERTIES FOLDER "Param Files")
if (WIN32)
- set ( sources
- ${sources}
- dirent.c)
-
- include_directories( before ${CMAKE_CURRENT_SOURCE_DIR})
+ target_sources(listxtp PRIVATE dirent.c )
endif ()
-
-add_executable( listxtp ${sources})
add_subdirectory(halibut)
-
+add_subdirectory(pngtoxpm)