summaryrefslogtreecommitdiff
path: root/distribution/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'distribution/CMakeLists.txt')
-rw-r--r--distribution/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/distribution/CMakeLists.txt b/distribution/CMakeLists.txt
index 119b684..30acac7 100644
--- a/distribution/CMakeLists.txt
+++ b/distribution/CMakeLists.txt
@@ -3,11 +3,7 @@ SET(CPACK_PACKAGE_DESCRIPTION "XTrackCad is a CAD program for designing model ra
SET(CPACK_PACKAGE_EXECUTABLES "xtrkcad;XTrkCAD ${XTRKCAD_VERSION}")
IF(WIN32)
# Add suffix
- IF(WIN64)
- SET(CPACK_PACKAGE_FILE_NAME "xtrkcad-setup-${XTRKCAD_VERSION}-x64")
- ELSE(WIN64)
- SET(CPACK_PACKAGE_FILE_NAME "xtrkcad-setup-${XTRKCAD_VERSION}-x86")
- ENDIF(WIN64)
+ SET(CPACK_PACKAGE_FILE_NAME "xtrkcad-setup-${XTRKCAD_VERSION}-${XTRKCAD_ARCH_SUBDIR}")
ELSE(WIN32)
SET(CPACK_PACKAGE_FILE_NAME "xtrkcad-setup-${XTRKCAD_VERSION}")
ENDIF(WIN32)