summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-05-08 23:32:28 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-05-08 23:32:28 +0200
commit55adddbc16f65732b57ab8585c47001fced91d77 (patch)
tree27e8239d48c8a6b353db356aff92ee4d225c0a0e /configure.ac
parentd3c90cdcdf56146af89056ed36bfcc7b4d4956c5 (diff)
Imported Upstream version 2.9.9upstream/2.9.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 345a344..ab41768 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(ipmiutil,2.9.8)
+AC_INIT(ipmiutil,2.9.9)
AC_CONFIG_SRCDIR(util/ipmiutil.c)
echo "ipmiutil version ${PACKAGE_VERSION}"
AM_CONFIG_HEADER(config.h)
@@ -136,6 +136,14 @@ AC_ARG_ENABLE([sha256],
fi]
)
+dnl configure for EKANALYZER, build with ekanalyzer function enabled
+AC_ARG_ENABLE([ekanalyzer],
+ [ --enable-ekanalyzer build with ekanalyzer function enabled.],
+ [if test "x$enableval" = "xyes"; then
+ OS_CFLAGS="$OS_CFLAGS -DHAVE_EKANAL"
+ fi]
+ )
+
GPL_CFLAGS=""
CROSS_LFLAGS=""
CROSS_CFLAGS=""
@@ -312,7 +320,8 @@ else
tmpc=/tmp/tmp.c
tmpo=/tmp/tmp.o
echo $ECHO_N "checking compile sign warning flags ... $ECHO_C"
- cfwarn="-Wno-pointer-sign -Wno-sign-conversion -Wunused-result"
+ cfwarn="-Wno-pointer-sign -Wno-sign-conversion"
+ # want "-Wno-unused-result", but unrecognized
echo "int main() { return(1); }" >$tmpc
$CC -o $tmpo -c $cfwarn $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then