summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2023-06-19 22:51:54 +0200
committerJörg Frings-Fürst <debian@jff.email>2023-06-19 22:51:54 +0200
commita75ccaa9a52b79788eea5fccfe6c3fc3dfc5a81d (patch)
treefd9e7b4ead2ca237d5836c1ccceaf336310b39dc /configure.ac
parente33cb500a5cefab12062415dd12b6192b59e5ae5 (diff)
parent06b8b4b51519bfcf8d210eb199e2eab09e0c6a64 (diff)
Merge branch 'release/debian/3.1.9-1'debian/3.1.9-1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 01525c8..821d56b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(ipmiutil,3.1.8)
+AC_INIT(ipmiutil,3.1.9)
AC_CONFIG_SRCDIR(util/ipmiutil.c)
echo "ipmiutil version ${PACKAGE_VERSION}"
AC_CONFIG_HEADERS(config.h)
@@ -333,7 +333,7 @@ else
echo $ECHO_N "checking compile sign warning flags ... $ECHO_C"
cfwarn="-Wno-pointer-sign -Wno-sign-conversion"
# want "-Wno-unused-result", but unrecognized
- echo "int main() { return(1); }" >$tmpc
+ echo "int main(void) { return(1); }" >$tmpc
$CC -o $tmpo -c $cfwarn $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then
cfwarn=
@@ -344,7 +344,7 @@ else
rm -f $tmpc $tmpo >/dev/null 2>&1
echo $ECHO_N "checking compile gnu warning flags ... $ECHO_C"
cfgnu="-Wgnu-designator"
- echo "int main() { return(1); }" >$tmpc
+ echo "int main(void) { return(1); }" >$tmpc
$CC -o $tmpo -c $cfgnu $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then
cfgnu=
@@ -355,7 +355,7 @@ else
rm -f $tmpc $tmpo >/dev/null 2>&1
echo $ECHO_N "checking strict aliasing warning flags ... $ECHO_C"
cfalias="-fno-strict-aliasing"
- echo "int main() { return(1); }" >$tmpc
+ echo "int main(void) { return(1); }" >$tmpc
$CC -o $tmpo -c $cfalias $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then
cfalias=
@@ -366,7 +366,8 @@ else
rm -f $tmpc $tmpo >/dev/null 2>&1
echo $ECHO_N "checking compile fortify flags ... $ECHO_C"
cfhard="-fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
- echo "int main() { alloca(100); return(1); }" >$tmpc
+ echo "#include <alloca.h>
+ int main(void) { alloca(100); return(1); }" >$tmpc
$CC -o $tmpo $cfhard $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then
cfhard=