summaryrefslogtreecommitdiff
path: root/debian/patches/002-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/002-build.patch')
-rw-r--r--debian/patches/002-build.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/patches/002-build.patch b/debian/patches/002-build.patch
new file mode 100644
index 0000000..dc1799e
--- /dev/null
+++ b/debian/patches/002-build.patch
@@ -0,0 +1,37 @@
+Description: add @INS_LIB@ to Makefiles
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2014-06-04
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/util/Makefile.am
+===================================================================
+--- trunk.orig/util/Makefile.am 2014-03-31 16:10:19.000000000 +0200
++++ trunk/util/Makefile.am 2014-05-26 19:11:11.998725060 +0200
+@@ -189,9 +189,9 @@
+ @INS_LIB@ cp -f isensor.h ievents.h $(DESTDIR)$(extradir)
+ @INS_LIB@ cp -f Makefile.sample $(DESTDIR)$(extradir)/Makefile
+ @INS_LIB@ cp -f $(DEV_LIB) $(DESTDIR)$(LIBDIR)
+- if [ "x$(SHRLINK)" != "x" ]; then \
++ @INS_LIB@ if [ "x$(SHRLINK)" != "x" ]; then \
+ @INS_LIB@ cp -f $(SHR_LIB) $(DESTDIR)$(LIBDIR) ; \
+- fi
++ @INS_LIB@ fi
+
+ clean-generic:
+ rm -f $(DEV_LIB) $(EXTRA_PROGRAMS) $(OLDPROGS) $(TESTPROGS) $(SHRLINK)
+Index: trunk/util/Makefile.in
+===================================================================
+--- trunk.orig/util/Makefile.in 2014-03-31 16:10:24.000000000 +0200
++++ trunk/util/Makefile.in 2014-05-26 19:11:25.698992815 +0200
+@@ -752,9 +752,9 @@
+ @INS_LIB@ cp -f isensor.h ievents.h $(DESTDIR)$(extradir)
+ @INS_LIB@ cp -f Makefile.sample $(DESTDIR)$(extradir)/Makefile
+ @INS_LIB@ cp -f $(DEV_LIB) $(DESTDIR)$(LIBDIR)
+- if [ "x$(SHRLINK)" != "x" ]; then \
++ @INS_LIB@ if [ "x$(SHRLINK)" != "x" ]; then \
+ @INS_LIB@ cp -f $(SHR_LIB) $(DESTDIR)$(LIBDIR) ; \
+- fi
++ @INS_LIB@ fi
+
+ clean-generic:
+ rm -f $(DEV_LIB) $(EXTRA_PROGRAMS) $(OLDPROGS) $(TESTPROGS) $(SHRLINK)