summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 20 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index 49191d6..44ad232 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,23 +1,31 @@
#!/usr/bin/make -f
-%:
- dh $@ --with autoreconf
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+#
+# Hardening
+#
+#
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-PKD = $(abspath $(dir $(MAKEFILE_LIST)))
-PKG = $(word 2,$(shell dpkg-parsechangelog -l$(PKD)/changelog | grep ^Source))
-VER ?= $(shell dpkg-parsechangelog -l$(PKD)/changelog | perl -ne 'print $$1 if m{^Version:\s+(?:\d+:)?(\d.*)(?:\-\d+.*)};')
-.PHONY: get-orig-source
-## http://wiki.debian.org/onlyjob/get-orig-source
-get-orig-source: $(info I: $(PKG)_$(VER))
- @echo "# Downloading..."
- uscan --noconf --verbose --rename --destdir=$(CURDIR) --check-dirname-level=0 --force-download --download-version $(VER) $(PKD)
+
+%:
+ dh $@ --with autotools-dev --with systemd
override_dh_auto_configure:
- dh_auto_configure -- --enable-gpl
+ $(CURDIR)/beforeconf.sh
+ dh_auto_configure
-# work around bug #670796
override_dh_autoreconf:
dh_autoreconf --exclude=mkinstalldirs
override_dh_installchangelogs:
dh_installchangelogs ChangeLog
+
+override_dh_installman:
+ dh_installman doc/iseltime.8
+ dh_installman