summaryrefslogtreecommitdiff
path: root/sample/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2021-04-26 22:25:42 +0200
committerJörg Frings-Fürst <debian@jff.email>2021-04-26 22:25:42 +0200
commit5d5f76cad47d13dc0dd4328c2172ddc1d4b19d7b (patch)
treecd59a8ea003d6768af284fc913353983e2794a58 /sample/Makefile.am
parenteac65ba44805c402f894b700b602c2e891f92a84 (diff)
parent96b0c9871630512ec2c2e84072da0085d68d740f (diff)
Merge branch 'release/debian/6.9.7.1-1'debian/6.9.7.1-1
Diffstat (limited to 'sample/Makefile.am')
-rw-r--r--sample/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/sample/Makefile.am b/sample/Makefile.am
index c2c4596..681cd2a 100644
--- a/sample/Makefile.am
+++ b/sample/Makefile.am
@@ -4,13 +4,13 @@ lib_onig = ../src/libonig.la
LDADD = $(lib_onig)
AM_CFLAGS = -Wall
-AM_LDFLAGS = -L$(prefix)/lib
+AM_LDFLAGS = -L$(libdir)
AM_CPPFLAGS = -I$(top_srcdir)/src
if ENABLE_POSIX_API
-TESTS = encode listcap names posix simple sql syntax user_property callout echo count bug_fix regset scan
+TESTS = encode listcap names posix simple sql syntax user_property callout echo count bug_fix regset scan callback_each_match
else
-TESTS = encode listcap names simple sql syntax user_property callout echo count bug_fix regset scan
+TESTS = encode listcap names simple sql syntax user_property callout echo count bug_fix regset scan callback_each_match
endif
check_PROGRAMS = $(TESTS)
@@ -29,6 +29,7 @@ count_SOURCES = count.c
bug_fix = bug_fix.c
regset_SOURCES = regset.c
scan_SOURCES = scan.c
+callback_each_match_SOURCES = callback_each_match.c
sampledir = .
@@ -49,3 +50,4 @@ endif
$(sampledir)/bug_fix
$(sampledir)/regset
$(sampledir)/scan
+ $(sampledir)/callback_each_match