summaryrefslogtreecommitdiff
path: root/windows/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2023-11-20 20:27:13 +0100
committerJörg Frings-Fürst <debian@jff.email>2023-11-20 20:27:13 +0100
commitacb44b8740ce860a4905a47f84520f132c6f76ac (patch)
tree4cc2df0d5849dc8ec395282157528a35e2b1829c /windows/CMakeLists.txt
parentc9281d179754ffffe24ba9a718d2c4f2e1b4bd5e (diff)
parente81090b75cd330ee5201f56e40d9424a1fc31a6a (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'windows/CMakeLists.txt')
-rw-r--r--windows/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/windows/CMakeLists.txt b/windows/CMakeLists.txt
new file mode 100644
index 0000000..ed59211
--- /dev/null
+++ b/windows/CMakeLists.txt
@@ -0,0 +1,8 @@
+
+add_executable(testc_windows testc.c)
+target_link_libraries(testc_windows onig)
+if(NOT MSVC)
+ target_compile_options(testc_windows
+ PRIVATE -finput-charset=cp932 -fexec-charset=cp932
+ )
+endif(NOT MSVC)