summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fc3885b..0880b2d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,11 @@ sanitize:
make
make all-test
+debug_out_sanitize:
+ make clean
+ ./configure CFLAGS="-O0 -g -fsanitize=address -DONIG_DEBUG_PARSE -DONIG_DEBUG_COMPILE" LDFLAGS="-fsanitize=address"
+ make
+
cov:
make lcov-clear
cd test; make CFLAGS="--coverage" test