summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2024-12-19 18:56:14 +0100
committerJörg Frings-Fürst <debian@jff.email>2024-12-19 18:56:14 +0100
commitf7bb1be5414854235b90e9863b37b8a79ade446c (patch)
tree18d041f054b65952e9c0c55a0df8193672291aaa /debian/rules
parent84a14edb40b406239ea3390d5ab2bce028551919 (diff)
Fix FTBFS on non-Linux architecturesdevelop
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d9f933e..1b0243f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,11 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_STRIP_FLAG = ""
STRIP = ""
endif
+ifeq (linux,$(DEB_HOST_ARCH_OS))
+ EXTRA_CONFIGURE_ARGS += --with-v4l
+else
+ EXTRA_CONFIGURE_ARGS += --without-v4l
+endif
%:
dh $@
@@ -48,7 +53,8 @@ endif
--with-avahi \
--enable-pnm-backend \
--with-usb \
- --disable-locking
+ --disable-locking \
+ $(EXTRA_CONFIGURE_ARGS)
override_dh_autoreconf:
dh_autoreconf -Xlibtool.m4