summaryrefslogtreecommitdiff
path: root/frontend/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'frontend/Makefile.am')
-rw-r--r--frontend/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/frontend/Makefile.am b/frontend/Makefile.am
index 9b92645..8573aba 100644
--- a/frontend/Makefile.am
+++ b/frontend/Makefile.am
@@ -44,5 +44,20 @@ tstbackend_LDADD += -lstdc++
endif
endif
-clean-local:
- rm -f test tstbackend
+BUILT_SOURCES = saned@.service saned.xinetd.conf
+
+EXTRA_DIST = saned.socket saned@.service.in saned.xinetd.conf.in
+
+CLEANFILES = $(EXTRA_PROGRAMS) $(BUILT_SOURCES)
+
+SUFFIXES = .in
+.in:
+ $(AM_V_GEN)
+ @if $(AM_V_P); then echo Generating $@ from $^; fi
+ @sed -e 's|@DATADIR@|$(datadir)|g' \
+ -e 's|@CONFIGDIR@|$(configdir)|g' \
+ -e 's|@DOCDIR@|$(docdir)|g' \
+ -e 's|@LIBDIR@|$(libdir)/sane|g' \
+ -e 's|@BINDIR@|$(bindir)|g' \
+ -e 's|@SBINDIR@|$(sbindir)|g' \
+ -e 's|@PACKAGEVERSION@|$(PACKAGE_VERSION)|g' $? > $@