summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2024-02-22 17:32:27 +0100
committerJörg Frings-Fürst <debian@jff.email>2024-02-22 17:32:27 +0100
commit2bb26608f735b6fc90c06a56793e1cf6e164830a (patch)
tree0b7ca7dcaaeb737b7e539ce4c3992d18c6949370 /data/meson.build
parent5c6c59a0325c2f3cc611b8186ac289d011c14369 (diff)
parent5303f650e34763817d7eeb1d3ba774bdec3e1a38 (diff)
Update upstream source from tag 'upstream/0.32.6'
Update to upstream version '0.32.6' with Debian dir 5219d541f047c3ea70dcf1edb7897dd0a7dedfb1
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/data/meson.build b/data/meson.build
index 9c17f0f..f04dbcb 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -9,7 +9,7 @@ podir = join_paths('..', 'po')
i18n.merge_file(input : 'org.gnome.Shotwell.appdata.xml.in',
output : 'org.gnome.Shotwell.appdata.xml',
- po_dir : join_paths('..', 'po'),
+ po_dir : podir,
type : 'xml',
install: true,
install_dir : join_paths(get_option('datadir'), 'metainfo'))
@@ -28,5 +28,15 @@ i18n.merge_file(input : 'org.gnome.Shotwell-Viewer.desktop.in',
install : true,
install_dir : join_paths(get_option('datadir'), 'applications'))
+auth_conf = configuration_data()
+auth_conf.set('libexecdir', join_paths(get_option('prefix'), get_option('libexecdir')))
+configure_file(
+ input : 'org.gnome.Shotwell.Auth.desktop.in',
+ output: 'org.gnome.Shotwell.Auth.desktop',
+ configuration: auth_conf,
+ install: true,
+ install_dir : join_paths(get_option('datadir'), 'applications')
+)
+
shotwell_resources = gnome.compile_resources('shotwell-resources',
'org.gnome.Shotwell.gresource.xml')