summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2023-07-14 10:04:16 +0200
committerJörg Frings-Fürst <debian@jff.email>2023-07-14 10:04:16 +0200
commit4ec8ba6ace7234ddc24a7d362a34d9055a83812c (patch)
tree9f2e04c7d498407d54437efcb4806bb0bc02053f /debian/rules
parentb86540b743f1a87a163ffb811c8fe22a01fefa38 (diff)
parent55fd5cdf9100840c12017b0423e4b8806cc23e08 (diff)
Merge branch 'release/debian/0.32.1-2'debian/0.32.1-2
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 2 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index 38a3150..8d4b33c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,23 +6,15 @@ export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
#Enable the apport option when building of Ubuntu
ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
- APPORT = -Dinstall-apport-hook=true
+ APPORT = -Dinstall_apport_hook=true
endif
%:
- dh $@ --buildsystem=meson --with gnome
+ dh $@ --buildsystem=meson
override_dh_auto_configure:
dh_auto_configure -- \
- --libexec=/usr/libexec \
-Dunity_support=true $(APPORT)
override_dh_gnome_clean:
dh_gnome_clean --no-control
-
-override_dh_install:
- dh_install
- # Remove unwanted la files
- rm -f debian/shotwell/usr/lib/*/shotwell/plugins/builtin/*.la
- rm -f debian/shotwell/usr/lib/*/*shotwell*.a
- rm -f debian/shotwell/usr/lib/*/*shotwell*.la