summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2024-02-22 17:32:07 +0100
committerJörg Frings-Fürst <debian@jff.email>2024-02-22 17:32:07 +0100
commit5303f650e34763817d7eeb1d3ba774bdec3e1a38 (patch)
tree8ad5028940b931abe0eee441e12357f970c656de /src/meson.build
parentf5a0cee8ccecc7b6c6c2d8e9fb6f6eecd53531fe (diff)
New upstream version 0.32.6upstream/0.32.6upstream
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index 460092e..25f967a 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -12,17 +12,25 @@ sw_graphics_processor = static_library('shotwell-graphics-processor',
vala_args : '--disable-assert',
install : false)
-processor = executable('shotwell-graphics-processor',
+executable('shotwell-graphics-processor',
['graphics-processor.vala'],
dependencies: [gio, gdk, gee],
link_with: sw_graphics_processor)
+executable('shotwell-authenticator',
+ [
+ 'authenticator.vala'
+ ],
+ dependencies: [gio],
+ include_directories: config_incdir,
+ install: true,
+ install_dir : join_paths(get_option('libexecdir'), 'shotwell')
+)
+
shotwell_deps = [gio, gee, sqlite, gtk, sqlite, posix, gphoto2,
gstreamer_pbu, gudev, gexiv2, gmodule,
libraw, libexif, sw_plugin]
-shotwell_libs = [sw_graphics_processor]
-
face_sources = (['faces/FacesBranch.vala',
'faces/FacePage.vala',
'faces/FaceShape.vala',