summaryrefslogtreecommitdiff
path: root/data/gsettings/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/gsettings/meson.build')
-rw-r--r--data/gsettings/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/data/gsettings/meson.build b/data/gsettings/meson.build
new file mode 100644
index 0000000..7e3c59a
--- /dev/null
+++ b/data/gsettings/meson.build
@@ -0,0 +1,13 @@
+schema_xml = files(
+ 'org.gnome.shotwell-extras.gschema.xml',
+ 'org.gnome.shotwell.gschema.xml',
+ 'org.yorba.shotwell-extras.gschema.xml',
+ 'org.yorba.shotwell.gschema.xml'
+)
+
+install_data(schema_xml,
+ install_dir : join_paths(get_option('datadir'), 'glib-2.0', 'schemas'))
+
+gnome.compile_schemas(
+ depend_files : schema_xml
+)