summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/data/meson.build b/data/meson.build
index 9c17f0f..f04dbcb 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -9,7 +9,7 @@ podir = join_paths('..', 'po')
i18n.merge_file(input : 'org.gnome.Shotwell.appdata.xml.in',
output : 'org.gnome.Shotwell.appdata.xml',
- po_dir : join_paths('..', 'po'),
+ po_dir : podir,
type : 'xml',
install: true,
install_dir : join_paths(get_option('datadir'), 'metainfo'))
@@ -28,5 +28,15 @@ i18n.merge_file(input : 'org.gnome.Shotwell-Viewer.desktop.in',
install : true,
install_dir : join_paths(get_option('datadir'), 'applications'))
+auth_conf = configuration_data()
+auth_conf.set('libexecdir', join_paths(get_option('prefix'), get_option('libexecdir')))
+configure_file(
+ input : 'org.gnome.Shotwell.Auth.desktop.in',
+ output: 'org.gnome.Shotwell.Auth.desktop',
+ configuration: auth_conf,
+ install: true,
+ install_dir : join_paths(get_option('datadir'), 'applications')
+)
+
shotwell_resources = gnome.compile_resources('shotwell-resources',
'org.gnome.Shotwell.gresource.xml')