summaryrefslogtreecommitdiff
path: root/plugins/shotwell-publishing/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/shotwell-publishing/meson.build')
-rw-r--r--plugins/shotwell-publishing/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/plugins/shotwell-publishing/meson.build b/plugins/shotwell-publishing/meson.build
index eeac177..a93726b 100644
--- a/plugins/shotwell-publishing/meson.build
+++ b/plugins/shotwell-publishing/meson.build
@@ -1,9 +1,9 @@
shotwell_publishing_sources = [
'shotwell-publishing.vala',
- 'FacebookPublishing.vala',
'FlickrPublishing.vala',
'TumblrPublishing.vala',
'YouTubePublishing.vala',
+ 'YoutubeUploader.vala',
'PiwigoPublishing.vala',
'PhotosPublisher.vala',
'PhotosService.vala',
@@ -13,13 +13,13 @@ shotwell_publishing_sources = [
shotwell_publishing_resources = gnome.compile_resources('publishing-resource',
'org.gnome.Shotwell.Publishing.gresource.xml',
- source_dir : meson.source_root())
+ source_dir : meson.project_source_root())
shared_module('shotwell-publishing',
shotwell_publishing_sources + shotwell_publishing_resources,
dependencies : [gtk, soup, gexiv2, gee, sw_plugin, json_glib,
- webkit, sw_plugin_common_dep, xml, gdata, gcr,
- gcr_ui, authenticator_dep],
+ webkit, sw_plugin_common_dep, xml, gcr,
+ gcr_ui, authenticator_dep, secret],
c_args : ['-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Publishing"',
'-DGCR_API_SUBJECT_TO_CHANGE'],
install: true,