summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2024-06-30 20:45:42 +0200
committerJörg Frings-Fürst <debian@jff.email>2024-06-30 20:45:42 +0200
commit26d8dd51f3ecc4bd6861ed5155acb3090a1983d4 (patch)
tree08d9369065e32f20a80f9cf916a5b1a468b39527 /meson.build
parent1676db749dc23da9fcd9c767de2f1e9a0c61b2b2 (diff)
New upstream version 46.0upstream/46.0upstream
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build26
1 files changed, 3 insertions, 23 deletions
diff --git a/meson.build b/meson.build
index 68266f3..ef5bc69 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project ('simple-scan', ['vala', 'c'],
- version: '44.0',
+ version: '46.0',
license: 'GPLv3+',
default_options: [
'warning_level=1',
@@ -20,10 +20,10 @@ icondir = join_paths (datadir, 'simple-scan', 'icons')
# Dependencies
glib_dep = dependency ('glib-2.0', version: '>= 2.38')
-gtk_dep = dependency ('gtk+-3.0', version: '>=3.24')
+gtk_dep = dependency ('gtk4', version: '>=4.10.0')
gmodule_dep = dependency ('gmodule-export-2.0')
gthread_dep = dependency ('gthread-2.0')
-libhandy_dep = dependency ('libhandy-1', version: '>= 1.6.0', required: false)
+libadwaita_dep = dependency('libadwaita-1', version: '>= 1.2.0')
zlib_dep = dependency ('zlib')
cairo_dep = dependency ('cairo')
gdk_pixbuf_dep = dependency ('gdk-pixbuf-2.0')
@@ -36,26 +36,6 @@ sane_dep = dependency ('sane-backends')
msgfmt = find_program ('msgfmt')
itstool = find_program ('itstool')
-libhandy_subproj = libhandy_dep
-if not libhandy_dep.found()
- libhandy_subproj = subproject(
- 'libhandy',
- default_options: [
- 'examples=false',
- 'glade_catalog=disabled',
- 'tests=false',
- ]
- )
-
- # When using libhandy as subproject, make sure we get the VAPI file
- libhandy_dep = declare_dependency(
- dependencies: [
- libhandy_subproj.get_variable('libhandy_dep'),
- libhandy_subproj.get_variable('libhandy_vapi'),
- ]
- )
-endif
-
subdir ('po')
subdir ('data')
subdir ('help')