summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/01_lpi.patch38
-rw-r--r--debian/patches/11_thunderbird_workaround.patch34
-rw-r--r--debian/patches/series1
3 files changed, 73 insertions, 0 deletions
diff --git a/debian/patches/01_lpi.patch b/debian/patches/01_lpi.patch
new file mode 100644
index 0000000..0ace6ef
--- /dev/null
+++ b/debian/patches/01_lpi.patch
@@ -0,0 +1,38 @@
+Origin: Ubuntu
+Description: Add launchpad-integration support.
+---
+ configure.ac | 1 +
+ src/ui.c | 5 +++++
+ 2 files changed, 6 insertions(+)
+
+--- simple-scan-0.9.10.orig/configure.ac
++++ simple-scan-0.9.10/configure.ac
+@@ -33,6 +33,7 @@ PKG_CHECK_MODULES(SIMPLE_SCAN, [
+ cairo-pdf
+ dbus-glib-1
+ gudev-1.0
++ launchpad-integration
+ ])
+
+ AC_CHECK_HEADERS([sane/sane.h],[],[AC_MSG_ERROR([SANE not found])])
+--- simple-scan-0.9.10.orig/src/ui.c
++++ simple-scan-0.9.10/src/ui.c
+@@ -16,6 +16,7 @@
+ #include <gconf/gconf-client.h>
+ #include <math.h>
+ #include <unistd.h> // TEMP: Needed for close() in get_temporary_filename()
++#include <launchpad-integration.h>
+
+ #include "ui.h"
+ #include "book-view.h"
+@@ -1308,6 +1309,10 @@ ui_load (SimpleScan *ui)
+ }
+ gtk_builder_connect_signals (builder, ui);
+
++ /* Add Launchpad integration */
++ launchpad_integration_set_sourcepackagename ("simple-scan");
++ launchpad_integration_add_items (GTK_WIDGET (gtk_builder_get_object (builder, "help_menu")), 1, TRUE, TRUE);
++
+ ui->priv->window = GTK_WIDGET (gtk_builder_get_object (builder, "simple_scan_window"));
+ ui->priv->preview_box = GTK_WIDGET (gtk_builder_get_object (builder, "preview_vbox"));
+ ui->priv->preview_area = GTK_WIDGET (gtk_builder_get_object (builder, "preview_area"));
diff --git a/debian/patches/11_thunderbird_workaround.patch b/debian/patches/11_thunderbird_workaround.patch
new file mode 100644
index 0000000..2d5a938
--- /dev/null
+++ b/debian/patches/11_thunderbird_workaround.patch
@@ -0,0 +1,34 @@
+## Description: add some description
+## Origin/Author: add some origin or author
+## Bug: bug URL
+Index: simple-scan-0.9.10/src/simple-scan.c
+===================================================================
+--- simple-scan-0.9.10.orig/src/simple-scan.c 2010-03-26 12:53:11.355296101 +1100
++++ simple-scan-0.9.10/src/simple-scan.c 2010-03-26 12:53:08.325311353 +1100
+@@ -343,7 +343,7 @@
+ /* NOTE: I'm not sure if this is a 100% safe strategy to use g_file_open_tmp(), close and
+ * use the filename but it appears to work in practise */
+
+- filename = g_strdup_printf ("%s-XXXXXX.%s", prefix, extension);
++ filename = g_strdup_printf ("%sXXXXXX.%s", prefix, extension);
+ fd = g_file_open_tmp (filename, &path, &error);
+ g_free (filename);
+ if (fd < 0) {
+@@ -371,7 +371,7 @@
+ gchar *path;
+
+ /* Open a temporary file */
+- path = get_temporary_filename ("scanned-document", "pdf");
++ path = get_temporary_filename ("scan", "pdf");
+ if (path) {
+ GFile *file;
+
+@@ -389,7 +389,7 @@
+ gchar *path;
+ GFile *file;
+
+- path = get_temporary_filename ("scanned-document", "jpg");
++ path = get_temporary_filename ("scan", "jpg");
+ if (!path) {
+ saved = FALSE;
+ break;
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..2d543b4
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+11_thunderbird_workaround.patch