summaryrefslogtreecommitdiff
path: root/app/cJSON/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:49 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:49 +0200
commit8dc8048d2cd4996825470bbfcb1e09e2a2630035 (patch)
tree9804282102f8c40d27407b9c94119b35eeb5013c /app/cJSON/CMakeLists.txt
parentc9d0740841fbe0539e42e66d3865672bfcd3ac02 (diff)
parentb6bd52cd7330a90fc0e44dbe6022551a8dd768a1 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'app/cJSON/CMakeLists.txt')
-rw-r--r--app/cJSON/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/app/cJSON/CMakeLists.txt b/app/cJSON/CMakeLists.txt
new file mode 100644
index 0000000..d4abca3
--- /dev/null
+++ b/app/cJSON/CMakeLists.txt
@@ -0,0 +1,13 @@
+#
+# build the cJSON object library
+
+add_library( cJSON "")
+
+target_sources(cJSON
+ PRIVATE
+ cJSON.c
+ PUBLIC
+ cJSON.h
+)
+
+target_include_directories(cJSON PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}) \ No newline at end of file