summaryrefslogtreecommitdiff
path: root/app/cJSON/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:30 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2024-07-03 10:19:30 +0200
commita14a7a0ccc9de76aeab0b2e4bbf58f1a79deedc2 (patch)
treee469179df67a0e0db49161a43cbf8076a189f6f4 /app/cJSON/CMakeLists.txt
parent5d2c2b27a6323e2666378b986129b2a7c2c39e5c (diff)
New upstream version 5.3.0GAupstream/5.3.0GAupstream
Diffstat (limited to 'app/cJSON/CMakeLists.txt')
-rw-r--r--app/cJSON/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/app/cJSON/CMakeLists.txt b/app/cJSON/CMakeLists.txt
new file mode 100644
index 0000000..d4abca3
--- /dev/null
+++ b/app/cJSON/CMakeLists.txt
@@ -0,0 +1,13 @@
+#
+# build the cJSON object library
+
+add_library( cJSON "")
+
+target_sources(cJSON
+ PRIVATE
+ cJSON.c
+ PUBLIC
+ cJSON.h
+)
+
+target_include_directories(cJSON PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}) \ No newline at end of file