summaryrefslogtreecommitdiff
path: root/app/tools/pngtoxpm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/tools/pngtoxpm/CMakeLists.txt')
-rw-r--r--app/tools/pngtoxpm/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/app/tools/pngtoxpm/CMakeLists.txt b/app/tools/pngtoxpm/CMakeLists.txt
new file mode 100644
index 0000000..54f697b
--- /dev/null
+++ b/app/tools/pngtoxpm/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Build pngtoxpm
+
+add_executable(pngtoxpm pngtoxpm.c)
+target_link_libraries(pngtoxpm
+ PRIVATE
+ FreeImage::FreeImage
+)
+
+if(WIN32)
+# copy dlls into the build dir for easier debugging
+ add_custom_command(
+ TARGET pngtoxpm POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy ${FREEIMAGE_SHAREDLIB} ${CMAKE_CURRENT_BINARY_DIR}
+ )
+ set(ENV{path} "${CMAKE_CURRENT_BINARY_DIR};$ENV{PATH}")
+endif()