summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-usr_gtk-3.patch13
-rw-r--r--debian/patches/0005-fix_link_lib_failed.patch41
-rw-r--r--debian/patches/0900-spelling-errors.patch87
-rw-r--r--debian/patches/0901-implicit-function-declaration.patch10
-rw-r--r--debian/patches/series5
5 files changed, 70 insertions, 86 deletions
diff --git a/debian/patches/0001-usr_gtk-3.patch b/debian/patches/0001-usr_gtk-3.patch
new file mode 100644
index 0000000..afe0689
--- /dev/null
+++ b/debian/patches/0001-usr_gtk-3.patch
@@ -0,0 +1,13 @@
+Index: trunk/CMakeLists.txt
+===================================================================
+--- trunk.orig/CMakeLists.txt
++++ trunk/CMakeLists.txt
+@@ -64,7 +64,7 @@ if(APPLE)
+ endif()
+
+ IF(UNIX)
+- PKG_CHECK_MODULES(GTK REQUIRED "gtk+-2.0")
++ PKG_CHECK_MODULES(GTK REQUIRED "gtk+-3.0")
+ ENDIF()
+
+ IF(APPLE)
diff --git a/debian/patches/0005-fix_link_lib_failed.patch b/debian/patches/0005-fix_link_lib_failed.patch
new file mode 100644
index 0000000..23deba2
--- /dev/null
+++ b/debian/patches/0005-fix_link_lib_failed.patch
@@ -0,0 +1,41 @@
+Description: fix_xtrkcad_build_failure
+Author: Yue Gui <yuemeng.gui@gmail.com>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1087474
+Forwarded: not-needed
+Last-Update: 2024-11-14 <YYYY-MM-DD, last update of the meta-information, optional>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/CMake/FindLibzip.cmake
++++ b/CMake/FindLibzip.cmake
+@@ -37,17 +37,23 @@
+ HINTS ${PC_LIBZIP_INCLUDE_DIRS})
+
+ if(UNIX AND NOT APPLE)
++ if(CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
+ find_library(LIBZIP_LIBRARY
+ NAMES libzip.a zip
+ PATHS
+- /usr/lib64
+- /usr/lib
+- /usr/local/lib64
+- /usr/local/lib
+- /sw/lib
+- /opt/local/lib
+- ${CMAKE_CURRENT_SOURCE_DIR}/app/tools/lib/linux
+- )
++ /usr/lib64
++ /usr/lib
++ /usr/local/lib64
++ /usr/local/lib
++ /sw/lib
++ /opt/local/lib
++ ${CMAKE_CURRENT_SOURCE_DIR}/app/tools/lib/linux
++ )
++ else()
++ find_library(LIBZIP_LIBRARY
++ NAMES zip
++ )
++ endif()
+ else()
+ find_library(LIBZIP_LIBRARY
+ NAMES zip)
diff --git a/debian/patches/0900-spelling-errors.patch b/debian/patches/0900-spelling-errors.patch
index 681a034..39ac3e9 100644
--- a/debian/patches/0900-spelling-errors.patch
+++ b/debian/patches/0900-spelling-errors.patch
@@ -4,94 +4,11 @@ Forwarded: https://sourceforge.net/p/xtrkcad-fork/bugs/165/
Last-Update: 2018-03-19
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-Index: trunk/app/help/genhelp.in
-===================================================================
---- trunk.orig/app/help/genhelp.in
-+++ trunk/app/help/genhelp.in
-@@ -112,7 +112,7 @@ cmdPan Pan or Zoom the Layout
- cmdParallel Create a parallel track
- cmdParameter Register register
- cmdPaste Copy objects from clipboard
--cmdPref Perferences dialog
-+cmdPref Preferences dialog
- cmdPricelist Display prices of turnouts, sectional tracks and structures
- cmdPrint Print the layout
- cmdPrmfile Loads and unloads parameter files
-Index: trunk/app/help/xtrkcad.info
-===================================================================
---- trunk.orig/app/help/xtrkcad.info
-+++ trunk/app/help/xtrkcad.info
-@@ -176,7 +176,7 @@ Register
- :cmdPaste
- Copy objects from clipboard
- :cmdPref
--Perferences dialog
-+Preferences dialog
- :cmdPricelist
- Display prices of turnouts, sectional tracks and structures
- :cmdPrint
-Index: trunk/app/i18n/de_DE.po
-===================================================================
---- trunk.orig/app/i18n/de_DE.po
-+++ trunk/app/i18n/de_DE.po
-@@ -6985,7 +6985,7 @@ msgid "Copy objects from clipboard"
- msgstr "Objekte von der Zwischenablage kopieren"
-
- #: ../../../../build/work/app/bin/bllnhlp.c:100
--msgid "Perferences dialog"
-+msgid "Preferences dialog"
- msgstr "Einstellungen"
-
- #: ../../../../build/work/app/bin/bllnhlp.c:101
-Index: trunk/app/i18n/fi.po
-===================================================================
---- trunk.orig/app/i18n/fi.po
-+++ trunk/app/i18n/fi.po
-@@ -390,7 +390,7 @@ msgstr "Junien hallinta"
-
- #: ../bin/ccontrol.c:386 ../bin/csensor.c:358 ../bin/csignal.c:486
- #, fuzzy
--msgid "Orgin X"
-+msgid "Origin X"
- msgstr "Marginaali"
-
- #: ../bin/ccontrol.c:388 ../bin/csensor.c:360 ../bin/csignal.c:488
-@@ -6843,7 +6843,7 @@ msgid "Copy objects from clipboard"
- msgstr "Liitä objektit leikepöydältä"
-
- #: ../../../../build/work/app/bin/bllnhlp.c:99
--msgid "Perferences dialog"
-+msgid "Preferences dialog"
- msgstr "Ominaisuudet"
-
- #: ../../../../build/work/app/bin/bllnhlp.c:100
-Index: trunk/app/i18n/pt_BR.po
-===================================================================
---- trunk.orig/app/i18n/pt_BR.po
-+++ trunk/app/i18n/pt_BR.po
-@@ -389,7 +389,7 @@ msgstr "Controle de trem"
-
- #: ../bin/ccontrol.c:386 ../bin/csensor.c:358 ../bin/csignal.c:486
- #, fuzzy
--msgid "Orgin X"
-+msgid "Origin X"
- msgstr "Margem"
-
- #: ../bin/ccontrol.c:388 ../bin/csensor.c:360 ../bin/csignal.c:488
-@@ -6680,7 +6680,7 @@ msgid "Copy objects from clipboard"
- msgstr "Copia objetos da área de transferencia"
-
- #: ../../../../build/work/app/bin/bllnhlp.c:99
--msgid "Perferences dialog"
-+msgid "Preferences dialog"
- msgstr "Caixa de diálogo de preferências"
-
- #: ../../../../build/work/app/bin/bllnhlp.c:100
Index: trunk/app/bin/csensor.c
===================================================================
--- trunk.orig/app/bin/csensor.c
+++ trunk/app/bin/csensor.c
-@@ -371,7 +371,7 @@ static paramData_t sensorEditPLs[] = {
+@@ -388,7 +388,7 @@ static paramData_t sensorEditPLs[] = {
#define I_SENSORNAME (0)
/*0*/ { PD_STRING, sensorEditName, "name", PDO_NOPREF|PDO_STRINGLIMITLENGTH, (void*)200, N_("Name"), 0, 0, sizeof(sensorEditName)},
#define I_ORIGX (1)
@@ -104,7 +21,7 @@ Index: trunk/app/bin/csignal.c
===================================================================
--- trunk.orig/app/bin/csignal.c
+++ trunk/app/bin/csignal.c
-@@ -491,7 +491,7 @@ static paramData_t signalEditPLs[] = {
+@@ -508,7 +508,7 @@ static paramData_t signalEditPLs[] = {
#define I_SIGNALNAME (0)
/*0*/ { PD_STRING, signalEditName, "name", PDO_NOPREF|PDO_STRINGLIMITLENGTH, (void*)200, N_("Name"), 0, 0, sizeof(signalEditName)},
#define I_ORIGX (1)
diff --git a/debian/patches/0901-implicit-function-declaration.patch b/debian/patches/0901-implicit-function-declaration.patch
new file mode 100644
index 0000000..dbf878b
--- /dev/null
+++ b/debian/patches/0901-implicit-function-declaration.patch
@@ -0,0 +1,10 @@
+--- a/app/bin/ctext.c
++++ b/app/bin/ctext.c
+@@ -36,6 +36,7 @@
+ void UpdateFontSizeList( long *, wList_p, wIndex_t );
+ long GetFontSize(long);
+ long GetFontSizeIndex(long size);
++void wSetSelectedFontSize(wFontSize_t size);
+
+ static wMenu_p textPopupM;
+
diff --git a/debian/patches/series b/debian/patches/series
index c6c3550..2017ae8 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,4 @@
-0900-spelling-errors.patch
+#0001-usr_gtk-3.patch
+0901-implicit-function-declaration.patch
+#0900-spelling-errors.patch
+0005-fix_link_lib_failed.patch