summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2019-08-07 09:32:48 +0200
committerJörg Frings-Fürst <debian@jff.email>2019-08-07 09:32:48 +0200
commit40f3d0030e6e98bcb02d6523e5ee48497dec49a6 (patch)
treea992f9a6acd3edc2c7bb6b1aba2e52084918c9ab /Makefile.am
parente25c754918ae26e8b9e68a47bc1af36248e91800 (diff)
New upstream version 6.9.3upstream/6.9.3
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6045eae..a0bbc7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,12 @@ pkgconfig_DATA = oniguruma.pc
all-test:
cd test; make test
+sanitize:
+ make clean
+ ./configure CC=clang CFLAGS="-O -g -fsanitize=address"
+ make
+ make all-test
+
cov:
make lcov-clear
cd test; make CFLAGS="--coverage" test