summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6045eae..a0bbc7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,12 @@ pkgconfig_DATA = oniguruma.pc
all-test:
cd test; make test
+sanitize:
+ make clean
+ ./configure CC=clang CFLAGS="-O -g -fsanitize=address"
+ make
+ make all-test
+
cov:
make lcov-clear
cd test; make CFLAGS="--coverage" test