summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2024-02-22 17:32:40 +0100
committerJörg Frings-Fürst <debian@jff.email>2024-02-22 17:32:40 +0100
commit2c3bc9ad65fc70efdd8e981b0bc49346b2ef646f (patch)
tree0b7ca7dcaaeb737b7e539ce4c3992d18c6949370 /src/meson.build
parent5c6c59a0325c2f3cc611b8186ac289d011c14369 (diff)
parent2bb26608f735b6fc90c06a56793e1cf6e164830a (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index 460092e..25f967a 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -12,17 +12,25 @@ sw_graphics_processor = static_library('shotwell-graphics-processor',
vala_args : '--disable-assert',
install : false)
-processor = executable('shotwell-graphics-processor',
+executable('shotwell-graphics-processor',
['graphics-processor.vala'],
dependencies: [gio, gdk, gee],
link_with: sw_graphics_processor)
+executable('shotwell-authenticator',
+ [
+ 'authenticator.vala'
+ ],
+ dependencies: [gio],
+ include_directories: config_incdir,
+ install: true,
+ install_dir : join_paths(get_option('libexecdir'), 'shotwell')
+)
+
shotwell_deps = [gio, gee, sqlite, gtk, sqlite, posix, gphoto2,
gstreamer_pbu, gudev, gexiv2, gmodule,
libraw, libexif, sw_plugin]
-shotwell_libs = [sw_graphics_processor]
-
face_sources = (['faces/FacesBranch.vala',
'faces/FacePage.vala',
'faces/FaceShape.vala',