summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index 460092e..25f967a 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -12,17 +12,25 @@ sw_graphics_processor = static_library('shotwell-graphics-processor',
vala_args : '--disable-assert',
install : false)
-processor = executable('shotwell-graphics-processor',
+executable('shotwell-graphics-processor',
['graphics-processor.vala'],
dependencies: [gio, gdk, gee],
link_with: sw_graphics_processor)
+executable('shotwell-authenticator',
+ [
+ 'authenticator.vala'
+ ],
+ dependencies: [gio],
+ include_directories: config_incdir,
+ install: true,
+ install_dir : join_paths(get_option('libexecdir'), 'shotwell')
+)
+
shotwell_deps = [gio, gee, sqlite, gtk, sqlite, posix, gphoto2,
gstreamer_pbu, gudev, gexiv2, gmodule,
libraw, libexif, sw_plugin]
-shotwell_libs = [sw_graphics_processor]
-
face_sources = (['faces/FacesBranch.vala',
'faces/FacePage.vala',
'faces/FaceShape.vala',